Need help? Check out our Support site, then

My website keeps timing out when I try to get into my WordPress site.

  1. I cannot get into my site without going to Google and going in that way. I have tried copying and pasting but I just cannot get back to Desktop without it telling me, "Page not found".

    The blog I need help with is

  2. It always used to but for some reason, nothing I try will get me to my blog site. I can't even open the WordPress blog on this computer but am able to open everything on my Surface.
    I did manage to get in by doing a Google search and clicking on one of the links which is how I was able to post the current blog but even that was very iffy as it too timed out. I didn't even know it had succeeded until I checked on my Surface. It's as though something is preventing the link up with the WordPress site.
    I thought it might be the video I loaded through Vimeo so I took it down but it didn't change anything.

  3. 1. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode.

    3. If you are running one of the browsers and versions listed at

    (a) Try clearing your browser’s cache

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS:

    Add both * and * to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary
    (c) And what any error reports you receive state.

  4. I tried the things that you mention but with little success. I ended up unloading and then reloading both Chrome and Firefox. I added Opera but still have the same problem, pages won't load and time out.
    So, I went back in and added the s to the http and now, the pages load out just fine.
    I have no idea why that worked.
    Thanks for your help.

  5. So, I went back in and added the s to the http and now, the pages load out just fine.

    That's good to know. Best wishes for trouble-free blogging.

Topic Closed

This topic has been closed to new replies.

About this Topic