Need help with private blog

  • Author
  • #1259162

    The blog I’m having problems with is private. I’m using the P2 theme. Things were going along smoothly, and then one person I invited accepted the invitation, but was not showing as a “user.” I sent her another invitation and she showed as THE ONLY USER. Now, no one can post comments. As administrator, I can neither post comments. The program will not allow me to resend invitations to those who are already members. It gives an error message that they are already users.

    All users with the exception of myself as administrator are registered as “authors.”

    Checking under “settings” and “discussions” the program says that I have no users.

    Can this be easily resolved, or will I have to delete all current users and send another invitation?

    The blog I need help with is



    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.


    Timethief. Thank you. Subscribed and am patient. After deleting that one individual appearing as the only user, under settings and discussion, other users can post. However, the program does say that the blog has no users.



    Howdy! If you go to your Dashboard, then to Users -> All Users, you should see everyone listed there. Is that not the case?


    Howdy sixhours! Thanks for the response.
    I can see all users that have accepted invitation. It’s under “settings” and “discussions” that it tells me there are no users. It is also in that place where yesterday, it had the one user listed and no one else could post comments until I deleted her.



    Hmm, that sounds normal, as no users are supposed to be displayed under Settings -> Discussion, only the Users menu.

    I’m not sure why adding one user would have impacted comments for the rest, though. Are you able to re-add her successfully, and still have everyone able to post comments?


    Thanks for the response, sixhours. I’ve not tried re-adding yet because she seems to have problems signing into that private blog through her wordpress account — says it won’t accept her handle, so she used another one.

    Somehow, when she first did that, she was able to enter and post responses, but not start a discussion. Neither did she have privileges of an “author” to edit and delete her comments. Also, she did not appear under “users.” She did not appear as anyone who had been sent an invitation to accept or pending. That did concern me.

    Then she contacted me on Saturday asking if she had been banned, because she wasn’t able to sign-in at all. I sent her another invitation and it went through because she was not appearing as having been sent an invitation previously. After she accepted is when all other users could no longer post, and her handle appeared under “settings” “discussion” as a user. Once I deleted that, others were able to post.

    It’s a weird situation.



    That’s definitely strange. :) Well, if you (or your friend) continue to experience problems, please post and I’ll be happy to investigate!


    Sixhours, thanks again. Seems to me that she should be able to sign-in through her word press account and WALLA! I’ve never been asked for a handle when signing-in, so am at a lost.

    Thanks for your time and concern.


    Now, I am able to post new posts, can enter admin and also upload media. However, when I try posting responses to comments, a message appears that says P2 is not connected to the Word Press server.

    I checked for discussion of the problem in WP forums, but they did not appear to be resolved.


    After searching support forums about the “not connected to Word Press server” problem, it appears that no one has resolved the problem unless their blog is through .org.

    I am very frustrated now and don’t know what to do to resolve it. How can a blog run for months without any problem, and suddenly develop this one out of the blue?


    Okay, just want to let you know that I spent hours going through the support forums, and eventually read a message that instructed to empty the cache. I deleted temporary internet files and everything is now working fine. If anyone else runs into this problem using, hopefully it can be resolved by deleting temporary internet files.



    Hi. I’m the person. I was able to log in to get here with my email and then my password – however, it did not show all the other blogs I subscribe to – in fact, it showed I don’t subscribe to any – yet yesterday I got an update from one of them that showed all of them, some I tried to delete a long time ago.

    Anyway, I was able to sign in to you with the same email and password that I used for blackbutterfly as well as another blog where I go. However, I can’t get into her chat. First it asks for my name – no matter what name I put, when I put in the password it says it is wrong and asks for my email and password. This time I put the email and password and got a thing saying if I wanted to view it, to request and invitation. It said I was logged in under a different name though, but when I tried to get there by that name I had the same thing happen. Anyway, maybe this time it will work?



    @blackbutterfly768, I’m glad you were able to get this resolved!

    @rachaelbs, it’s hard to say without your account information. It sounds like you have two accounts, one which was invited to view your friend’s blog and one which was not. You may find the following support document helpful if you need to reset your password because you can’t log in to one of those accounts:

    If you continue to experience problems logging in and/or seeing your blogs, can you please create a new topic in the general Support forum?

    This forum is specifically for issues with Themes, and the staff in general support are more experienced with solving login issues than I. :)

The topic ‘Need help with private blog’ is closed to new replies.