Need to refresh page to get the right font

  • Author
    Posts
  • #1426540

    Hi, I don’t understand why, when people first arrive on my site, the name of my website “dekalaz” is not in the good font. If you refresh the page, you’ll get the good one. This problem is really annoying for me, many thanks for your help.

    Marion

    The blog I need help with is dekalaz.com.

    #1426717

    Hi, are you still experiencing this issue? I went to your site with three different browsers and I had to refresh the first time to get your custom fonts to show, but had no issues after that first time. That was while on a very slow internet connection.

    #1426724

    Hi, Yes, unfortunately, I’m still experiencing it. It represents a lot for me, such a shame to show my blog with this first font especially to the graphic world. How could I fix it please ? I don’t want to have to refresh the page.

    #1426728

    mrdirby
    Member

    I didn’t have this issue when I just visited your site.

    The problem is probably in the cashing of the linked font and once the page is loaded the fonts are in the browser cashe. If this is a typekit loading situation then there isn’t much you can do about it.

    It looks like the class wf-active is present in your custom fonts. @thesacredpath do you know if it is possible to set a wf-inactive class to the site-title so an image or alternate font would appear if the fonts don’t load?

    #1426740

    I checked http://dekalaz.com/ just now using Chrome 29.0.1547.65 and Safari 6.0.5 on Mac OS X 10.8.4, and I didn’t have to refresh to see the custom fonts.

    @misspapayeverte, if you’re still having trouble, could you try clearing browser cache as the first troubleshooting step?
    http://en.support.wordpress.com/browser-issues/#clear-your-cache-and-cookies

    #1426741

    do you know if it is possible to set a wf-inactive class to the site-title so an image or alternate font would appear if the fonts don’t load?

    I don’t think you’d need a wf-inactive class, since using the wf-active class is more specific, if you just wrote a selector without it at the beginning, then the wf-active one would take precedence whenever it tried to load. However, it’s a moot point if the problem is that the fonts start to get loaded and then don’t finish for whatever reason. I’m not sure that’s what’s happening anyway though — can’t really tell without more information from the misspapayeverte about her local network settings, browser version info, and what errors she may be seeing in the browser console if she’s willing to take a look at that kind of stuff.

    First step should be to try clearing browser cache and cookies, that way we’ll know that step was done and can rule out a local browser settings issue as the cause of the problem.

    #1426742

    I cleaned browser cache but it is still the wrong font which appears first. Very, very embarrassing. Even if the internet connection is slow, we shouldn’t have this kind of dilemma :(

    #1426743

    Since I have tried testing once and I can’t repeat the problem myself, and mrdirby also reported he was unable to see the problem and thesacredpath reported he saw it once but then it went away, it may be something that’s only happening under a specific set of circumstances. To try to help you, I need to try to find out what those are.

    Are you able to try testing on multiple browsers and reply back here to let us know if the problem is limited to one browser for you or if it happens in all browsers?

    Can you take a screenshot of the entire browser window after a first pageload with the strong font and then reload and take a screenshot of again showing the correct font? This will help me to see the problem more clearly and it will also help me report it to our developers if I can verify the problem is not something specific to your location/setup.
    http://en.support.wordpress.com/make-a-screenshot/

    #1426744

    I tried multiple browsers and this is the same problem. Here are the screenshots :

    The wrong one :
    /Users/LittleM/Desktop/dekalaz.png

    The good one :
    /Users/LittleM/Desktop/Capture d’écran 2013-09-17 à 21.32.46.png

    #1426745

    I’m not sure that you’ve got the pictures. If not, tell me how to send them please. Many thanks.

    #1426746

    mrdirby
    Member

    Can you upload the photos through Media in your dashboard and post those links here.

    #1426747

    Ok, I downloaded the screenshots in my Media. Thanks :)

    #1426748

    Thanks for uploading screenshots.

    I’m adding the links here for reference:

    good: http://dekalaz.files.wordpress.com/2013/09/capture-d_c3a9cran-2013-09-17-c3a0-21-32-46.png

    wrong: http://dekalaz.files.wordpress.com/2013/09/dekalaz.png

    [Update: I had the same link posted twice before. I’ve fixed it now.]

    #1426749

    I have tried testing again and I still can’t see the wrong version. Here are the browsers I re-tested:
    * Chrome 29.0.1547.65 on Mac OS X 10.8.4
    * Firefox 23.0.1 on MacOS 10.8.4
    * Safari 6.0.5 on MacOS 10.8.4
    * Internet Explorer 9 on Windows 7

    Is anyone else from the forums able to help test?

    If you can help test, please go to http://dekalaz.com/ and (on the first pageload, without refreshing) let us know if the site title font matches this image or not?
    http://dekalaz.files.wordpress.com/2013/09/capture-d_c3a9cran-2013-09-17-c3a0-21-32-46.png

    #1426750

    mrdirby
    Member
    #1426751

    mrdirby
    Member

    When Updated to Firefox 24 I got the same incorrect font to load after resetting the cashe.

    #1426752

    @mrdirby, looks like you’re seeing the wrong font in all cases! Does it change to this if you refresh any of those views?

    #1426753

    mrdirby
    Member

    Yes. The correct font loads then.

    #1426754

    Ok, I can’t seem to trigger the same behavior. Thanks so much for testing and posting feedback. I’ll test a little more to see what I can find out. I may come back with more questions. :)

    #1426755

    mrdirby
    Member

    Seems to be working now. I was going to check the code on the bad page load but chrome and safari loaded the correct font on cashe refresh.

The topic ‘Need to refresh page to get the right font’ is closed to new replies.