Need help? Check out our Support site, then

New blog registration goes blank

  1. edvardaspocius

    I want to register a new WP blog (that would be my second WB blog), but as soon as I enter all the necessary details and press 'create blog', the page goes blank and nothing happens. Any idea what to do?

    I'm talking about this page:


  2. I am trying to create one as well and it will not let me.

  3. Please try clearing your browser cache and cookies and see if that helps. If not please try using another browser. Note that I have flagged this thread for Staff attention.

  4. I am having same troubles.

  5. edvardaspocius

    Thanks, but nothing helps. I've tried to use Mozilla, IE9 and Chrome... Cache and cookies are also deleted.

  6. Please be patient while waiting for Staff attention.

  7. Me too!

  8. Well, my guess based on nothing but these posts above is that Staff could be working on that area and may have temorarily disabled the feature.

  9. I'm having the same problem. I've tried three different browsers.

  10. I cannot create a new one too -_____- They really need to solve this problem

  11. Same here! I also have used three different browsers now: Chrome, Explorer, and Firefox none working.

  12. Reply on this thread once anyone is able to make one :)

    That way we'll all get notified! Unless maybe someone from WordPress will do that hopefully :0)

  13. edvardaspocius

    It's still all quiet on the western front guys. Let's wait patiently :)

  14. I have posted twice above to reassure you all that this thread is flagged for Staff attention and to request your patience while waiting.

  15. Hi there,

    Thanks for reporting this everyone. We're aware of the issue(s) with the sign-up process and have got someone looking at it, it should be fixed within a few moments.

    Thanks for your patience :)

  16. @jkudish
    Thanks for the confirmation. :)

  17. Hi again,

    I just got confirmation that this issue is now resolved. Please try again :)

    If you're still having issues, please try clearing your cache and cookies ( before posting on the forums or contacting support.


  18. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic