New editor – how to edit size of photo?

  • Author
    Posts
  • #2500154

    More than just with the +/- tool??? Where is the old customization in the edit screen??? Why on earth did you change the post editor??? It worked fine! I want to make my photos a specific size, not just random +/-!!!!!!!!!!

    The blog I need help with is flourishandknot.com.

    #2500284

    If it ain’t broke, don’t fix it. There appears to be a fixation with ‘techies’ to keep on tinkering with things and once again WordPress have made an unwelcome dog’s dinner out of what used to be a pleasant experience.

    #2500287

    The -/+ buttons will size images according to the preset sizes which are specific sizes. Try clicking the “-” button a couple times and that should take you to the medium size.

    If that doesn’t help, can you let me know exactly what size you were aiming for that isn’t working for you?

    #2500292

    What about the feature that enabled enlarging of posted images?

    #2500294

    What about the feature that enabled enlarging of posted images?

    That should be working. The -/+ buttons should cycle through the preset image sizes: thumbnail, medium, large, and full size (the max size of the uploaded images).

    If the “+” goes away after trying to enlarge the image too far, that probably means your original image is not large enough to be made any bigger. The size is limited to the uploaded image size.

    @collectireland, if there is a specific image you’d like me to look at on your blog, please reply with a link to a specific post where the image can be seen and I will take a closer look for you.

    #2500307

    What I’m saying is that, in the past, when a picture was uploaded and the page published a photo could be clicked on and would enlarge but this doesn’t happen now.

    #2500320

    I like my verticals 480×705 (they start as 750×1102) and my pictures on my gallery-style pages to all be 300 wide. (I say “style” because I can’t actually make a gallery on wp that will allow the pictures to be clickable URL links). How do I get these specific sizes?

    #2500346

    terryhurt
    Member

    I always upload my images full size so that when a blog post is made live and the reader clicks on an image it changes to full size. I did this with 18 images for a new blog less than a week ago (haven’t made it live yet) but now when I click Preview only about half of them can be viewed full size – seemingly randomly chosen by wordpress. In the edit mode I no longer get the option to properly edit the images already added – only + and – buttons which are already set to their maximums. This is a real backward step – why are you not allowing me to choose the size I want my readers to view the images at? Is this a bug that will be corrected? Please??!!

    #2500347

    @collectireland, my apologies, I didn’t understand before because you posted your comment on a thread about image sizing which is separate. To link an image to a larger version of itself, insert the image and then click the link icon in the editor. The link there will default to the URL for the original image. Can you try it out and see if that will work for you?

    #2500348

    @flourishandknot, thank you for the extra detail. That helps very much.

    To get fine-tuned control of the image sizes like you want, there are a few options:

    One option would be to adjust the size constraints in WP Admin > Settings > Media. Once that is done, you can use the -/+ buttons to cycle through the sizes you have set there.

    Another option would be to edit the HTML manually. (This doesn’t seem like a good option for a common update though.)

    If neither of those wll work, then you can switch back to /wp-admin in the short term until the advanced editing features such sizing an image exactly can be added to the new WordPress.com.

    #2500351

    @terryhurt, the image sizes shouldn’t have randomly changed. If you’d like to tell me the draft title, I can have a look to see if I can figure out what might have happened. However, it may just have been an odd case of switching in the middle and new posts you write in the future won’t have the problem. The default size for any new images you add now should be full size.

    #2500370

    terryhurt
    Member

    Hi, thanks for looking into this. The draft piece is called Dense Mist, Grimspound, if you could take a look. I know these were all full sized originally because I looked at the Preview only a couple of days ago and was able to see all images at full screen when I clicked on them. Hope there's a way to fix this without me having to delete them and reload…

    #2500417

    @terryhurt, I misunderstood the first time around and was only looking at the inserted size (the images are all full size) but not at whether or not the images were linked back to the original one. I looked at the draft titled “Dense mist, Grimspound” and I do see what you mean, but I cannot tell whether or not the draft changed before or after the editor was updated (so this is a bit of a rare case because of that).

    To fix this, you do not need to remove and re-insert the image. What you should do is open the post in the editor and click each image and then click the link icon in the edit toolbar. The URL field will b pre-filled with a link to the original image. Click the “Add Link” button to use it.

    #2500503

    But the media settings options do not specify horizontal vs vertical shots? So am I not going to get the wrong dimensions for one of those two orientations?? (I.e. 750×1102 would be for vertical, but if I use those dimensions, will my horizontal pics show up smaller than 1102 wide??)

    #2500505

    terryhurt
    Member

    Thanks for your helpful reply. Now all fixed and all photos on the piece viewable at full size by clicking on them. Will this be something I have to watch for routinely, or was this just a temporary glitch while the editor was being updated? Not a big deal, just curious, thanks again.

    #2500509

    buzzanniebee
    Member

    I hate this new format. The photos have all bled into each other. It looks hideous. What was wrong with the old way of posting???? Bring it back. This is horrible

    http://anniebeebuzz.com/2015/11/17/surprising-finds-6/

    #2500543

    @flourishandknot the size restrictions are the maximum size for the longest side. For example, if you have a 600×400 image and 300×300 Medium image limit it would be resized to 300×200 at the Medium size to maintain the aspect ratio. If it was a 400×600 image instead it would be resized to 200×300.

    #2500544

    @terryhunt For now you will need to click the link icon for each image, but as we add back advanced image settings in future updates we will remember your preference and auto-link them to the full size image if that is the selection you prefer.

    #2500545

    @buzzanniebee You should be able to press enter/return in the Editor between images to leave a gap between them

    #2500553

    buzzanniebee
    Member

    I pressed enter and return and there was a gap when on the editing page. However, that was lost once the post was published. I had to go back in and have a line with — — — — — — in order for there to be a space. This definitely needs fixing. I understand about how to resize the pics. It is the gaps which have disappeared and that looks awful. I hope it can be fixed.
    Thanks for your reply

The topic ‘New editor – how to edit size of photo?’ is closed to new replies.