New Gallery formats aren't working as expected.

  • Author
    Posts
  • #1095439

    dougstinson
    Member

    rectangular gallery displays only 4 of 7 images. Square displays all 7, but first image is larger than the rest.

    The blog I need help with is dougstinson.wordpress.com.

    #1095611

    virginiar0m0
    Member

    same problem here. my theme is nishita, my blog is http://holzfeder.wordpress.com/

    #1095612

    1tess
    Moderator Emeritus

    Please provide links to specific posts where this problem is happening.
    Start with http:// so the links are clickable.
    If this is a bug, then staff needs to see them in order to determine how to fix it.

    #1095613

    justjennifer
    Moderator

    The new “type” parameter, especially square and circle” work best in multiples of 3, otherwise the “leftover” thumbnails are sized to fill the entire width of the content posting area. This is how it works.

    #1095629

    dougstinson
    Member

    Here is the code:
    [gallery type="rectangular" ids="497,498,499,500,501,502,503"]

    and here is the link to the blog post:
    http://stinsonphotography.wordpress.com/2012/12/02/the-dance-of-light/

    #1095630

    justjennifer
    Moderator

    Do all the images show up if you default back to the thumbnail grid style?

    Do you have the mosaic set as default in your Dashboard>Settings>Media? If so, you needn’t add type=”rectangular” to your Gallery shortcode.

    #1095634

    dougstinson
    Member

    All images show up in the default thumbnail style and in the square style. It is only in “rectangular” that only 4 of the 7 show.

    I’ve tried it both ways: setting mosaic as the default and no special shortcode and not having it as a fault and using the special short code. I’ve also tried doing both!

    #1095640

    justjennifer
    Moderator

    All the images are visible in the Photo Carousel, so I’m stumped!

    I’ve tagged this for Staff assistance; please be patient while they get back to you.

    #1095641

    justjennifer
    Moderator

    @holzfeder since you are having the same problem with Nishita, please give us a direct link to the post where this is happening, starting with http:// to make it clickable.

    #1095642

    dougstinson
    Member

    Thank you, justjennifer

    #1095645

    justjennifer
    Moderator

    You’re welcome

    I can confirm that in Nishita using Gallery types with a sidebar breaks the Gallery types (all!).

    Screenshot – Nishita full width (Note that even here the rectangular “mosaic” does not behave like in other themes.)

    Screenshot – Nishita with sidebar

    #1095650

    virginiar0m0
    Member

    I cannot give you a link because I tried a square gallery with 4 pictures but I wont publish it , it looks terrible.

    After Justjennifers message telling that it only works with multiples of 3 I made the gallery with just 3 of the pictures (which also does not look much better: 2 on the top, 1 down, not really a nice mosaic): http://holzfeder.wordpress.com/2012/12/13/showing-more-power/ (the gallery is at the bottom)

    #1095655

    zandyring
    Staff

    I have also tested this, and you are correct: this is not functioning as intended.

    I’ve alerted the internal team, and I will report back.

    Thank you for bringing our attention to this!

    #1095656

    justjennifer
    Moderator

    @zandyring- again, thanks. Please let them know that most every responsive/flexible width theme is involved, not just Nishita. There have been a number of forum threads on this.

    #1095657

    zandyring
    Staff

    Thanks @justjennifer – I did talk to the team and there is some awareness on this, so the wheels are in motion.

    In the meantime, I recommend using a different gallery display option until a new fix is deployed.

    #1095666

    I am having a similar problem with the same code:
    [gallery type="rectangular" ids="2848,2849,2850,2851,2852,2853,2854,2855,2856,2857,2858,2859,2860,2861,2862,2863"]
    The problem that I have is that the pictures will be displayed when Internet Explorer is used but not with google chrome.
    Also when Internet Explorer is used the first picture is stretched out and deformed.
    http://cookingacrosstheglobe.com/2012/12/22/agedashi-tofu-%E6%8F%9A%E3%81%92%E5%87%BA%E3%81%97%E8%B1%86%E8%85%90/

    #1095667

    zandyring
    Staff

    Thank you for the report on that, Cookingacrossthe globe. Our recommended browsers are Firefox and Chrome, so it’s interesting to know that you’re seeing an issue with Chrome. What version are you using?

    #1095668

    We are currently looking into a solution for this issue. We’ll post back once it’s deployed. Thanks for the report!

    #1095669

    Hello,

    We pushed out a fix for this a little while ago. If you are following this thread and have experienced an issues with tiled galleries. Please check out the problem posts again. If you still notice a display issue, please post a link here with the browser you are using to view it.

    I’ve check all of the links provided in this post and they are looking great to me.

    #1095670

    justjennifer
    Moderator

    @cookingacrosstheglobe, Your problem sounds similar to the one here. I did just encounter the problem you mention in Chrome23, but then the pictures suddenly appeared without needing to refresh.

    I’m thinking that this may be due to the size of the original image you are uploading, rather than the problem I linked to above. Your images are 3648×2746 pixel dimension. These images are being dynamically resized to their display size on your site (considerably smaller pixel-wise) and there is every reason to resize your images in an image editing program before uploading, including preserving image clarity, shortening image loading time and maximizing your 3GB of free storage space.

    @michaelfields– Thanks! Nishita is looking good (fixed width with sidebar) as well as Yoko (responsive width). No dropped images and all “type” Galleries resize well to a resized browser window in a responsive width theme. I’ll continue checking other themes as time allows.

The topic ‘New Gallery formats aren't working as expected.’ is closed to new replies.