New Gallery formats aren't working as expected.

  • Author
    Posts
  • #1095671

    @justjennifer – Glad to hear it! Thanks for testing on your sites :)

    #1095672

    justjennifer
    Moderator

    @michaelfields- I don’t know why but Able continues to be troublesome.

    At full width, without a sidebar, in this post, published after the new Media Manager was implemented, the tiled mosaic works completely fine and then in this post, published before the new Media Manager was implemented and where all three Gallery types are used in a single post, the tiled mosaic (rectangular) behaves exactly like my above screenshot for Nishita. The Gallery thumbnails appear in a single line across the width of the content area, rather than being a tiled mosaic. Resizing the browser window (in this case FF 17.0.1) does not change anything, however, adding a sidebar does make the tiled mosaic appear.

    If need be, I’ll leave Able up on my Gallery demo site through the weekend, though I may be swapping out other themes from time to time.

    #1095673

    @justjennifer Thanks for the report, I’ll see what I can figure out about this.

    On another note, if you want to display a shortcode as text on your site you can use a little trick. Add and extra square bracket to each end like this:

    [[gallery type="rectangular"]]

    and it will display like this:

    [gallery type="rectangular"]

    instead of being rendered as a shortcode.

    #1095674

    justjennifer
    Moderator

    @michaelfields- Thanks and thanks for the tip! Appreciated.

    #1095675

    @justjennifer Regarding the gallery you reported, I was able to reproduce this and reported it to our developers. It’s a crazy bug that will only happen if the content area is larger than 1000 pixels and your gallery has 5 images and 3 of them are vertical and two are horizontal.

    Someone will report back when we find a resolution to this.

    #1095677

    mashet
    Member

    Hi,
    I have been facing a similar issue with the rectangular mosaic gallery ever since I started using the new uploader. Tried removing larger images from a draft I am working on and the problem seems to persist.

    Here is the link to a previous post where I gave up and posted a default gallery.
    http://theurgetowander.com/2012/12/27/a-gentle-initiation-to-the-land-of-a-million-elephants/

    Is there some way we can opt for the old uploader? It worked just fine!

    #1095678

    justjennifer
    Moderator

    No, but do please try the tiled mosaic again after the fix applied recently. When you edit the Gallery, select “Tiles” for the mosaic.

    If you default back to the thumbnail grid gallery, then there won’t be anything for Staff to troubleshoot. :)

    Also, do make sure you are using an up-to-date web browser, preferably Firefox or Chrome.

    #1095679

    Hi there,
    I’ve given the tiled gallery a go for the first time and find the top shot is vast with 10 images:

    http://mikeosbornphoto.com/2012/12/30/top-shots-of-2012/

    Removing one of them or adding a couple more would ruin the concept of this post, so it’s a case of living with the big ‘number one’.

    I find the tiles are generally far too large and can’t figure out a way of resizing them, so for now my default is the old style.

    It would be great to use the mosaic more often, so I look forward to hearing about any fixes.

    With best wishes,
    Mike

    #1095680

    justjennifer
    Moderator

    You cannot resize the images in the tiled Gallery types, as together they are designed to fill the entire width of the post content area. It looks to me like you are using the “square tiles” (i.e. square) type for your post. I’ve found it’s best in multiples of 3. Otherwise, you could try the “Tiles” (i.e. rectangle) and see if you like that better.

    Also, if you are using the default thumbnail grid, you can modify the Gallery shortcode in the Post Editor’s Text tab to change the size of the image being displayed in the Gallery. You can read more about that here:
    http://en.support.wordpress.com/images/gallery/#gallery-shortcode

    Even more here:
    http://gammagirl.wordpress.com/2008/07/27/not-the-official-wordpresscom-gallery-faq/

    and there are demos here: http://agallerydemo.wordpress.com/

    #1095681

    Hi Jennifer,
    Many thanks for your answer. I tried a tiled gallery with a set of images divisible by three, and it’s certainly more uniform.

    Ah, I didn’t realise the default gallery sizes could be altered. I’ll certainly have a play with that.

    On a similar vein, I put together a gallery from the Media Library – some of the images are already featured in another gallery. Any captions that I had duplicated. I imagine the only way around this is to upload the images to library again so they are attached to a fresh post.

    Many thanks for your guidance, it’s much appreciated.

    With best wishes,
    Mike

    #1095682

    justjennifer
    Moderator

    You’ll have to experiment with the Captions. It seemed like at one time they were attached to a particular blog post or page (as opposed to the image) and then they weren’t. But of course uploading the images again gives you a clean slate.

    You’re most welcome.

    #1095683

    They appear to be attached to images at the moment, so reloading seems to be the way to go. That or you choose not to have captions on images that happen to appear in more than one gallery.

    My next experiment is length of caption and how it renders in a post – all good fun!

    Thanks once again, Jennifer.

    #1095684

    justjennifer
    Moderator

    Captions should be short, in my opinion, but also you’ve got the image description as well and both can have clickable links in them.

    Cheers!

    #1095685

    Yes, I agree. If it’s too long then it should probably be part of the body text. Good to learn about clickable links – I was unaware of that. Thanks!

    #1095686

    mashet
    Member

    The fix seems to have sorted it out! Thanks Jennifer.

    #1095687

    drelynn
    Member

    I have updated to the most recent version of wordpress. However, I am not given the option of the “cool mosaic” as a default in Settings > Media.

    I am attempting to set up a gallery page with either a slideshow or “square” type gallery but because I don’t even have the option of “cool mosaic” in my media settings, I cannot attempt to alter the code / text of the page.

    Do you know why this is?

    http://drelynn.com/photography

    #1095688

    justjennifer
    Moderator

    I have updated to the most recent version of wordpress.

    which means you are posting in the wrong forum. This is the support forum for sites hosted by WordPress.com. Please read this for better clarity http://support.wordpress.com/com-vs-org/

    For help with your self-hosted site using the standalone WordPress software, please head over to http://wordpress.org/support/

    #1095691

    justjennifer
    Moderator
    #1095692

    IMHO this is definitely a bug, but I have not heard back from the developers of the tiled gallery plugin yet, I’ll post back here when we find a resolution to this.

    #1095693

    bcr8tive
    Member

    I can’t get anything but the default gallery settings to work. None of the new tiling features will display. (Circle, mosaic etc)
    I can’t find out yet if this is a WordPress issue, a conflict with my theme, or what it is…

    Glad I found this thread though ❤

The topic ‘New Gallery formats aren't working as expected.’ is closed to new replies.