New mosaic image feature not working for me?

  • Author
  • #1032451



    I followed the instructions in your latest supper post to turn on the mosaic image insertion feature but I can’t seem to get it working – nothing has changed when I use insert image in new post – no option to make the image circular or position it, for example are shown.

    Can you advise please?


    The blog I need help with is


    I’m with Susie! Have tried to no avail. Another step-by-step tutorial for non HTML or code types (that would be me) would be MOST appreciated! And in much detail than you think I’ll ever need, lol. That mosaic feature is so cool and I’d love to be able to use it. Many thanks. I’m at (email redacted)



    I got it to work for me but I don’t have time to post complete instructions as I’m preparing for Thanksgiving.
    Official announcement here >
    I used these instructions:

    … to give your Gallery a more homogeneous display, you can also set all your Gallery photos to display as a Mosaic by checking the box in your Dashboard > Settings > Media >Image Gallery Carousel >Tiled Galleries > __ Display all your gallery pictures in a cool mosaic.



    Once you turn on the Mosaic feature under Media Settings, you have to insert multiple photos in a Post or Page using the Gallery feature, following these instructions.

    No point in setting columns or sort order in the Gallery tab of the Image Uploader because the Mosaic seems to ignore them in favor of giving you a Gallery that fills the full width of your theme’s content area.

    If you still have questions after reading the official announcement and the Support doc, please post them here.



    For me it worked like this:

    I uploaded pictures I wanted to add and firstly I inserted them into post and editted to the size and title I wanted (I didn’t put caption, because both title and caption shows and for me it’s not looking nice) and then I put this code [gallery type="square"] in ‘text’. As I inserted pictures, I had to remove them from post. You can put title in ‘gallery’ settings so inserting can be skipped.

    I hope this helped :)



    All, thanks for the help.

    Anouskie, I tried that but i met be doing something wrong as it removes the pictures when I do that (I didn’t overtype anything, just added the [gallery type="square"] . I did manage to sort of get the pictures to go mosaic but couldn’t for the life of me work out how to get them to show as circles, even using text.



    Then put other code for circled pictures. You need to check this official post someone posted above.

    Pictures don’t show in post, to check them you need to preview post. All you need to do is upload pictures from your computer and put code in ‘text’ tab.



    Ahhhh they don’t show until you preview!

    Thanks Anouskie




    You’re welcome :)



    There are two ways you can invoke the new Gallery tiled mosaic/rectangle display

    The first way changes the Gallery thumbnail display globally on your site by checking the box in your Dashboard > Settings > Media >Image Gallery Carousel >Tiled Galleries > __ Display all your gallery pictures in a cool mosaic. This means that all Galleries on your site will display as a tiled mosaic.

    The second way is to modify the Gallery shortcode in the Post Editor’s Text tab to add the type=”rectangle” parameter. This can be done on a post-by-post or page-by-page basis.

    If you’ve changed your Gallery display globally using the first method, you do not need to modify the Gallery shortcode to display your Gallery images as a tiled mosaic. *

    *You only need to modify the Gallery shortcode if you want your Gallery thumbnails to display as either the circle or square type.


    You guys: I’m a creative artist and NOT a geek or tech type. You’re not telling me where to insert that code for a rectangle. I’ve tried within brackets, within brackets with spaces AND without, after something else, first….I can go on and on. I need many more details than anyone has laid out.

    If I have the global command enabled, which I do now, how do I get the pictures to display as a true mosaic? Now all the pictures I’ve uploaded to my gallery tab don’t *all* show up and they have what I’m gonna call sliders or zippers at the bottom of what DOES show up so you can see the whole photo. VERY DISCOURAGING. I’ve spent many hours on this and cannot get it to work. Kindly, Jennifer, spell it out for an idiot (that would, apparently, be me). Also, by checking that little box on the settings page it messed up the one gallery page I did have in the past (two nice columns) and I had to re-do that one, inserting all the photos “by hand” as well. I am not pleased. I AM FRUSTRATED!!!

    I am VERY unhappy with all these changes that I can’t get to work and all I want to do is curse. I won’t, but I want to. ;-)

    Please give me exact details as to where and how the code should go. More details than you think I need. PLEASE.



    HI Maura, I am sorry this isn’t working for you and I’ll do my best to try and help.

    When you tick the box for “Display all your Galleries in a cool mosaic” and Save under Media Settings, that is all you should need to do to get the tiled mosaic when you’ve inserted a Gallery according to these instructions. You don’t have to modify the Gallery shortcode any further. (See my note above)

    Also, there is a chance that the theme you are using is also part of the problem. I tried Sunspot on my Gallery demo site with the result that some Galleries displayed oddly.

    But, if you are having trouble with specific posts, won’t you please post a direct link to those posts so we can have a look at it?


    Jennifer, I’ve already redone the two posts that I wanted to use Galleries in. The previous one which worked in two columns and an upcoming one so I thank you most profusely but there’s no point in showing them to you now. I must admit that the “cool mosaic” worked on my blog for about ten minutes one day and then quit. I’m really HAPPY to know it’s my theme and not ME!!!!! I’ll quit trying to use the Gallery function and then I won’t be so frustrated. As a calligrapher, graphic designer and amateur photographer (among other things) I want my blog to look its best…but NOT at the cost of losing what little sanity I have left or days at a time. So — waving and winking at you! — will just continue plodding along with what I *can* get to work and that varies from day to day for me.

    Having said all that, it stinks that it doesn’t work across as advertised. Your reply has been most gracious and I thank you for that.



    When I use the gallery shortcode “rectangle” on my blog I get sliders under all rows of photographs. When I use the shortcode “square” One photo appears big while the rest appear as square same is the case with the shortcode circle. The site is and the theme is Splendio by DesignDisease. Can anyone please help to sort out this issue.

    Thanks in advance.

The topic ‘New mosaic image feature not working for me?’ is closed to new replies.