New posts don't get posted to Facebook

  • Author
    Posts
  • #708220

    johnjsal
    Member

    In my settings it shows I am “Connected” (with a green dot) to Facebook, and within Facebook itself WordPress appears as an application with the permission to post to my wall. But none of my posts, including my latest today, appear on my wall. Why doesn’t this feature work for me?

    Thanks,
    John Salerno

    The blog I need help with is johnjsal.wordpress.com.

    #708388

    johnjsal
    Member

    I should add that next to my “New Post” text box is the following message:

    To enable Publicize: Facebook, you will need to authorize your WordPress.com account on Cogito to connect with your Facebook account.

    Clicking the link below will take you to Facebook where you will need to log in and click “allow” several times.

    Authorize connection with Facebook

    However, I clicked the link already but nothing happens except the page seems to refresh and I get taken to my WordPress settings. The first time I clicked the link I was asked if I wished to leave the page, but I said no. Since then, I don’t get that question and nothing relating to Facebook seems to happen.

    However, like I said above, WordPress appears in my Facebook permissions already.

    #708403

    timethief
    Member

    Hello there,
    If you have not set up Publicize here are the instructions. If you have and it’s not working for you please try the full reconnect procedure detailed at http://en.support.wordpress.com/publicize/#reconnecting-facebook including step 3 (removing the FB app), which is probably the most important step.

    #708422

    johnjsal
    Member

    Thank you! I think the full reconnect worked, because now I can click on “Set options” under Facebook in my WordPress Sharing Settings, whereas before clicking on that link brought up an empty box.

    Thanks!

    #708423

    johnjsal
    Member

    Hmm, except under “My Blogs” there is still a yellow box with the message about authorizing Facebook. I already did this, so I don’t know if that’s just a remnant of the process….

The topic ‘New posts don't get posted to Facebook’ is closed to new replies.