Need help? Check out our Support site, then

New (sub) Page shows no content

  1. playswithsticks

    Blog/page in question:

    The page is published, public, and has a single image and text. Nothing fancy. It shows as a page with NO content. I've refreshed, and even tried it in a completely different browser (thus it can't be a caching issue in the browser).

    Editing shows the full content without a problem.

    NOTE: I am not saying my content is there, but blank. The SPACE for the content is even there on the page. It simply isn't being rendered at all.

    If you check this out and see content, it means then that has some sort of dramatic lag between when it says something is "published", and when it is actually available. Again - I've tried different browsers, so this is not a browser cache issue. I suppose it could be a server-cache issue (but that's WP's problem)

    All other pages are fine, but this one is the ONLY "sub"-page on the site. And it doesn't render. So....?

    The blog I need help with is

  2. playswithsticks

    I mean the space for the content is NOT even there

  3. playswithsticks

    Note - in addition to testing with 3 different browsers (IE8, Chrome, FF) I've also tested it not logged in - and get the same result - content portion not rendered.

  4. playswithsticks

    Uses stock pilcrow theme, with this CSS "added" to it, to get some fixed indents on one page: {
    } {

  5. playswithsticks

    So this is looking like a problem with the Pilcrow theme - I experimented with previewing the site with other themes and the page renders (for example, with the Enterprise theme)

    Is this a bug in the theme, or are sub-pages a "feature" that may or may not work in general with a theme?

  6. playswithsticks

    I've switched to the "greyzed" theme, which seems to not have the problem. That doesn't mean "pilcrow" shouldn't be fixed.

  7. No one has complained of this, and since you have switched away from Pilcrow, we can't take a look.

  8. playswithsticks

    I can tell you what the problem is - the page gives you several template options, and I used "links". It appears that if I used "default", then it would work. So the "links" template doesn't work with subpages.

    And it can be worked with easily - just use pilcrow, create a page, a sub page, and use the "links" template for the subpage. You should be able to repro the problem. If it isn't important enough for WP to fix an official template, then so be it.

  9. The "links" page is a special page for displaying the links that you set up at "links" in the dashboard (your blogroll). When you choose that template, and you have links defined then it will show those links on that page (you then don't have to use the links widget in the sidebar).

  10. The "links" page template will never show text or images that you put into a page using that template. There is actually nothing to fix. Things were working as they should.

    Go to my test blog and click "links" in the top navigation to see what the links page does.

  11. playswithsticks

    I hear what you say, but it remains a fact that previewing other themes on that same page that was set to the "links" template - those themes DID show the image and text.

  12. That's because only a few themes support the links template:
    When you switch to a theme that doesn't support the template, "that same page" will be just a regular static page (and if you check the page editor you'll see that the option isn't present in the Attributes module).

  13. playswithsticks

    So you mean in this case, if the new theme doesn't have the template, it uses the default template? That would explain it a bit. With that and the other tidbits here, I think the answer is complete!

  14. Yes, if the new theme doesn't have the template (and about ninety of them don't have it), it uses the default template.

Topic Closed

This topic has been closed to new replies.

About this Topic