New Twitter Timeline Widget Not Working

  • Author
    Posts
  • #1373253

    https://en.forums.wordpress.com/topic/new-twitter-timeline-widget-not-working?replies=3

    I followed the instructions on the above link and did all the 4 steps. However, my Twitter timeline widget is still showing up on my blog as “My Tweets” where the widget is supposed to be.

    I am using Firefox 22.0.

    The blog I need help with is invisibleautistic.wordpress.com.

    #1373403

    I am also having the same problem. “Error: Twitter did not respond. Please wait a few minutes and refresh this page.” It’s been at least one day since I added the widget. I’m using the latest Chrome browser and also tried https://.
    https://baynetlibrary.wordpress.com/
    The twitter widget is in the primary sidebar at the bottom.

    #1373405

    justjennifer
    Moderator

    Did you first create the timeline widget on twitter under the Settings there?

    See this Support doc for details and make sure you are talking about the twitter timeline widget. The old twitter widget no longer works

    http://en.support.wordpress.com/widgets/twitter-timeline-widget/#twitter-timeline-widget

    #1373410

    Ah, ok, swapped the widgets and it’s now working. Thanks!

    #1373413

    I did first create the twitter timeline widget on Twitter. Unlike baynetlibrary, I don’t get any error messages actually. It just shows up on my blog as “My Tweets” which isn’t a link. So I’m still not sure what the problem is.

    #1373414

    To add more details:

    STEP 1:
    I create twitter widget through Twitter first using the following steps: Settings –> Widgets. I check the boxes for “Exclude replies” and “Auto-expand photos.” I do not opt out of tailoring Twitter in any way. Code is already provided when I hit create, and I changed nothing to it. I save my changes.

    STEP 2:
    Go to WordPress. WordPress widget says “Twitter Timeline.” I input the Widget ID as instructed by WordPress, but when I click save, the Widget ID disappears. Is this normal?

    #1373415

    Also, do I need Java plugin for this to work?

    #1373416

    Never mind. I figured out what went wrong. Thanks

    #1373463

    hopnut
    Member

    Hi –

    I am having the same ‘My Tweets’ issue.

    It only manifests itself in Chrome though.
    Looks fine in IE and in FF.

    Have switched off AdBlocker for the site.

    Stumped (and frustrated).

    #1373465

    I’m having the same problem. The tweets were showing up properly while my site was set to “private.” I went live with it yesterday and now all I see is the header for “My Tweets.”

    I have verified that the widget ID is correct. I have even deleted, re-added and reconfigured the widget. No change.

    Help! My website is isabellanorse.com

    #1373471

    raggykate
    Member

    I’m having exactly the same problem as above. Please, please help.

    raggykate.wordpress.com

    #1373472

    justjennifer
    Moderator

    @raggykate – How long has it been since you created the widget on twitter? Did you enter your widget ID # in the correct line in the timeline widget? http://en.support.wordpress.com/widgets/twitter-timeline-widget/#twitter-timeline-widget

    #1373473

    raggykate
    Member

    Hi just worked out the problem! It is a stupid mistake but it may be worth sharing this with others as it seems people are struggling with this as well:

    When you create the twitter widget, you only need to copy the CODE (the long number) into the wordpress editor. I was copying the whole URL as this was what twitter automatically selects!!

    #1373474

    justjennifer
    Moderator

    :) Glad you worked it out!

    #1373475

    utsire
    Member

    Unfortunately, I have a similar problem but no resolution. I’m using the latest Twitter widget and have checked, double-checked, deleted and added the widget back and still no joy – all it shows is “My Tweets” and the link goes nowhere. Both on Chrome & FF the Widget is there but just shows “My Tweets” with a dead link.

    I’ve checked the 18 character Twitter ID – all numeric, no char – as shown when you edit the Widget on Twitter.

    I’ve even checked the underlying element in the Chrome browser and it has the correct “data-widget-id=” as shown on Twitter and the Widget setup.

    The blog in question is An Accidental PM

    #1373476

    utsire
    Member

    OK, seems to be working now; I think I may have encountered a firewall issue. Once I checked from another site it now seems to be populating.

The topic ‘New Twitter Timeline Widget Not Working’ is closed to new replies.