Newly forced to allow Google Javascript

  • Author
  • #1834128


    Since today Im forced to allow google javascript in order to write a new post. Nearly every button depends on now.
    Why is that?

    The blog worked fine without it. Is there any benefit? Am I the only one who isnt happy about google creeping into every little corner of the web?

    Thanks in advance.


    No, you are not the only one to have noticed and is concerned about this. What is going on here?


    Hi there!

    I’m not currently seeing this myself. Can you tell me what page you’re seeing this on, what you’re clicking on, and what browser you’re using?

    Thanks for the info!



    I could be off base but is it possible that these two bloggers are running browsers that do not have JavaScript enabled?


    Will both of you please make sure you are runnung a browser and e version of it found here Then also make sure that you have both JavaScript and third-party cookies enabled.


    You’re totally right @timethief! I completely forgot you can toggle JavaScript in browser settings. Thanks for catching that! :)



    Glad to help and you’re welcome.



    Sorry, but that was no help at all. We are not talking about general enabling of JS, but of exceptional enabling of JS.

    Its obvious and no problem that WORDPRESS cant be used without JS. JS makes WordPress comfortable. But since May 13 we are forced to allow JS for Untill May 13 it was not necessary to allow JS for

    This is new and we dont see the sense behind it.


    Hi dokumentor!

    I understand that this is new. It looks like you were using Firefox when you first submitted this thread, and I know Firefox just had a major update. Sometimes browsers will change their settings when you update, so it’s still a good idea to check and make sure that JavaScript is enabled in your browser as timethief suggested.

    Also, my questions about where specifically you’re being required to allow JavaScript to run will help me figure out why you’re seeing this and what possibly triggered it on our end.

    Any information you can give me so that I can recreate the problem is greatly appreciated, since if I can’t recreate it, I won’t be able to troubleshoot it very effectively!



    Hi Shawna!

    Im using Firefox but thats not the problem, as Im always using the newest version.

    Its the WP-code, that has been changed.

    Im using Firefox-Noscript-Addon which enables to allow or forbid JS for different domains. So in the past Google-JS was forbidden, when I was blogging, while and other necessary domains like were allowed.

    Since May 13 its impossible to write a new post in WPs dashboard without being allowed.

    Nearly every single button for formatting text in the dashboard depends on Google-JS now.
    Maybe ask one of your code-programmers. He will confirm this.

    Thx in advance!



    And what is the URL of the blog in question?


    Hello again!

    Thanks so much for that information! It was really helpful.

    I looked into this and it’s related to our geotagging feature.

    The actual mapping library is only loaded when the Add Location button is clicked, but we do load a general purpose library outside of that. For your reference, here’s the general purpose library we’re loading:

    Currently, there is no way to disable this. However if you have specific concerns about it, I’m happy to bring those to our developers!


    Kudos documentor for not giving up on explaining.

    I still can’t see why it is mandatory for wordpress bloggers to tell Google each time you edit a post. After all Google have their own blog sphere, and it could be an active reflected choice for some to use wordpress instead.


    Hi there!

    I just chatted with our developers about this more. They’ve deployed a fix that should no longer require that Google’s JS loader library be loaded for you to create and publish a new blog post.

    Please note that if you’re blocking script from, you will not see the Add Location button.

    Let me know if you’re still having issues!




    All engines running smooth and quiet again.

    Best regards,

The topic ‘Newly forced to allow Google Javascript’ is closed to new replies.