News page and menu problems

  • Author
    Posts
  • #1252914

    ckaltoft
    Member

    I’ve set my landing page to be a static page, which works fine. I’ve called it ‘home’. Problem is that now my blog posts aren’t visible. I’ve renamed them ‘news’.

    When I look at the ‘menu structure’ all the 4 pages and News section are there. However when I look at the website the News section is not there. Not sure why this should be. I know the data is still there, as if I click on Posts in dashboard they’ve not gone.

    Can anyone help, please?

    The blog I need help with is christinekaltoft.co.uk.

    #1252996

    raincoaster
    Member

    On the Settings->General page, you’ve set your static page to be the landing page, but what did you delegate as the Posts page?

    #1253019

    justpi
    Member

    Raincoaster means Settings > Reading.
    a) Did you create a page in Pages > Add New, title it “News”, and set it as your posts page in Settings > Reading?
    b) Assuming you’ve done that, you need to correct your custom menu, because at the moment it’s the News tab that links to your blog front (the Home tab links to your welcome page itself). Go to Appearance > Menus, delete the Home and News items you have added, open the Pages module, click View All, select Home:Home and News, click Add to menu, drag to change their order, save.

    #1253027

    ckaltoft
    Member

    Thanks. The posts page in settings, reading, doesn’t give me the option of using news. It simply doesn’t show it in the drop down list.

    #1253028

    ckaltoft
    Member

    Anyway I’ve removed News and Home from the Menu.

    However when I go to Pages it doesn’t say view all, so maybe I’m in the wrong place. It does list all the pages but News isn’t there. I think this is the wrong place actually as there’s not an option of changing order, although I know I’ve seen that elsewhere.

    #1253031

    justpi
    Member

    Please read my previous reply more carefully: #a says you must first create a page in Pages > Add New and title it “News”; #b says open the Pages module in Appearance > Menus.

    #1253039

    ckaltoft
    Member

    Thank you – you’re right – it does, and very helpful it was too! Now solved – many thanks! :-)

    #1253049

    justpi
    Member

    You’re welcome.
    Note that one doesn’t expect the posts page to open in a new browser window.

The topic ‘News page and menu problems’ is closed to new replies.