no blog stream on main page??

  • Author
  • #1052994

    Hello all, I’m new at this so pardon any simply questions, however, it seems that I don’t have a chronological blog stream. This should be on the first page, right? When I go to my address,, the first thing that comes up is the home page without any posts on it and I have to click on the right hand column to view my blog posts separately. Is this how its supposed to be?? Any help greatly appreciated!

    The blog I need help with is



    Your “home” page by default is the running page for blog posts.



    The most common error bloggers amke thinking they can create static page and label it as a category and then expect to see the page automatically update. That’s not possible. Only the dynamic Categories pages created by the software will automatically update.

    Pages are static and are for content that rarely changes. They sit outside of the blog structure and you cannot post to multiple pages in any blog.

    There is only one main page for posts in a blog and all posts will display on the main blog page. There is no way to exclude posts from the main posts (blog) page. By default the front page of the blog “Home” will display your posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then you can create a static front page “Welcome” for your site and a “Blog” page for posts.

    Though there is only one dynamic page in a blog for posts and we cannot post to more than that one page, we can create the appearance that we have posted to more than one page. We organize posts by assigning categories to them. You can create a custom menu and add the dynamic categories pages created by the software into the custom menu.

    Here’s a link to a custom menu walk through >

    There are many common errors, misunderstanding and misconceptions when creating custom menus and you can read about them here >



    edit: “amke thinking” ought to have been “make is thinking”



    You have set your blog to open on a static page called Home. Change it to open on Blog; you do that on the Settings->Reading page (or it might be Settings->General).


    Thank you both for that! That had me stumped for a while. Greatly appreciated.



    You’re welcome from me.



    One silly question regarding the Twenty Eleven Theme.

    I’m using to make a website for my wife, with one of the pages being a Blog, and the rest static pages.

    The template I’m using for the static pages is Showcase, because the space between the header and the body is not so big, menu titles are not displayed again in the body, and I find it more suitable for a “normal” page.

    For some reason, in all the pages using this template, Posts appear at the end of the page. I guess is something by default with this theme, and I would like to know if there is a way to avoid this, so Post only appear on the Blog section?




    You post here is off-topic and will cause confusion. Please post your own thread >

The topic ‘no blog stream on main page??’ is closed to new replies.