no box for comments

  • Author
  • #668452

    The box to allow comments is missing from my blog. I’ve followed all the instructions given under comments and discussions. They usually don’t work, and when they have worked and the box for comments has appeared, it’s disappeared again the next time I’ve looked.

    The blog I need help with is



    Bottom line: I visited your blog and it’s operating normally. The front page of our blogs “showcases” content and the comment boxes are not displayed until we click the post title or leave a comment link. When we do that the post opens on it’s own page and all comments are displayed below the post. In a new blog that has no comments or only a few this may be hard to comprehend but when you have a blog with many entries and many comments you will comprehend why this is. Page loading time is a pagreranking factor. We have 3- 4 seconds before visitors click out. If all posts and comments were fully displayed on the front pages of our blogs they would be a mile long and take a very long time to load.


    Thank you very much, timethief. Can’t believe I got such a full answer so quickly.



    You’re welcome. As you are new to I can recommend a comprehensive tutorial. The Learn tutorial is divided into progressive levels and presented as a series:
    Best wishes with your blog. :)


    Thanks for the link. Sorry to trouble you again, but can you tell me where the post title and leave a comment link are?


    I would very much like to remove the comment box from my frontpage, but can not figure out how to, can you help?

    Thank you very much.



    Every time publish a post it has a title and that title is a permalink. When clicked it will give rise to the post opening on it’s own page. As your are using Wu Wei click the title on your latest post and scroll to the bottom of it. You will see this:

    No comments Post your own or leave a trackback: Trackback URL
    Leave a Reply

    and a box for leaving a comment below it.



    @ journalistrikkebergquist
    We set up all comments on this page > Settings > Discussion. It’s the default page. We can override the default setting on any post or page as well. See here:

The topic ‘no box for comments’ is closed to new replies.