No previews of images on main blog

  • Author
    Posts
  • #1016748

    edduffill
    Member

    Hi there, I’m having trouble with my blog displaying images I post in their preview on the main blog. If you head to my site http://www.thatartistcalledslam.com you can see one post ‘politial graffiti’ has a preview because I uploaded it from my phone as an image post. The one after, ‘virgin media designs’ has a preview too. The Virgin one and the next 2 I uploaded from my laptop either by directly inserting them in to a post from from the gallery, or just clicking insert picture in a new post and uploading it from my computer, and these are the ones that haven’t got previews.

    Am I doing something wrong when I’m uploading picture in to a post? Could it be to do with the theme?

    Thanks.

    The blog I need help with is thatartistcalledslam.com.

    #1016827

    timethief
    Member

    The gray boxes you see will continue to appear until you upload featured images. In Oxygen you can either have a Home page that displays your posts or a static front page ie. a Showcase template. http://en.support.wordpress.com/pages/front-page/#setting-up-a-static-front-page

    Showcase page template
    When you first activate Oxygen, you’ll see your posts in a traditional blog format but if you’d like to showcase your content in an online magazine-like fashion, then you can use the Showcase Page template. …

    Sticky post thumbnails are 750 pixels wide in the featured slider
    Regular post thumbnails are 450 pixels wide
    http://en.support.wordpress.com/posts/post-visibility/#sticky-posts
    Oxygen
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image

    #1016828

    edduffill
    Member

    Thanks for the help, I get the static front page part but that’s not what I’m after, I still want the front age to be my blog, but I cant figure out why the Virgin Media post included a preview of the image and the recent 2 haven’t when I posted them in the same way, is it to do with the size of the image?

    Thanks

    #1016838

    timethief
    Member

    The size of featured images is critical.

    #1016852

    edduffill
    Member

    Seems to be some confusion here, I’m not looking to change my featured image, that’s set as the SLAM title at the top of the page and I want it to remain the same throughout the site. My question is how do I change the grey boxes with each post to a preview of the image I’ve included in the post, it did it with the Virgin Media post and I didn’t change anything to do with featured images I just inserted it in to a post and posted it.

    #1016857

    timethief
    Member

    The SLAM title at the top of the page is the custom header image.
    http://en.support.wordpress.com/themes/custom-header-image/

    #1016861

    edduffill
    Member

    Ok where would the featured image display? Is that what you mean by the grey boxes? The link you sent before that talks about featured images is showing them as customer header images. When I click screen options theres no option to show a featured image, and when I click it on a picture already on there it doesn’t seem to make a difference.

    #1016864

    edduffill
    Member

    As in this link you sent http://en.support.wordpress.com/featured-images/ This talks about having a featured image at the top of different pages. That’s not what I want, I want the empty grey boxes above each post on the blog to show previews of the image I posted like it has done on the earlier posts.

    Thanks.

    #1016874

    edduffill
    Member

    Sorted it! Didn’t realise you had to switch on individual featured image on each post, I found the link. Any idea though why is does this automatically when uploading from the iphone app?

    #1016988

    tiffthegreat
    Member

    thatartistcalledslam, would you mind clarifying how you solved it, please? I’m experiencing the same thing you were talking about.

    #1016989

    edduffill
    Member

    Sure, so to replace the empty grey boxes with previews of the image in your post (or any image)…

    When you’re writing a post through the dashboard, once you’ve inserted your picture in to the post and written what you need to write, scroll down and look in the bottom right corner of the screen and you should see a box saying Featured Image and an option to set featured image.

    Then locate the picture, if you’ve inserted it to your post already it’ll be in the media library, and click Show, scroll down past the sizes and you’ll see ‘use as featured image’. Click this, scroll down and click Save Changes, close the box and you’re done.

    You’ll then see the image in that box in the corner and it’ll show up in those grey boxes. It’s handy as if you only write text but want an image too you can upload one. When doing it on the mobile app it seems to do it automatically.

    Hope this helps.

The topic ‘No previews of images on main blog’ is closed to new replies.