No “Publish” Button?

  • Author
  • #403707

    I try to publish a new post, or edit a post, and there seems to be no way to publish. I can’t save or publish what I have edited or tried to post.

    The blog I need help with is


    A link to your blog would be helpful…


    The button is sitting in the upper right corner. You should have a box there named “Publish”.


    Also, are you signed in as an administrator?


    i am the owner of the forum, im signed in and trying to edit a page, and there is no publish or update page button. i am not new with wordpress, ive been using it for several months


    here is a picture:
    my blog is:


    oh i got it. FINALLY just had to go to page options


    I will have to check to see if I am signed in as an administrator. It is “my” blog, so I have been assuming that I am automatically allowed.

    Here is a link:

    When I click on “New Post” (near the top of the screen), and then put a new post together, there seems to be no button for publishing.


    This also happens when I try to edit a post or a page.



    What browser and version are you using? Do you see a scroll bar at the bottom of the page when you’re writing a post?


    Google Chrome. I downloaded it about a week and half ago. I believe it was the latest version at the time.

    Maybe the browser is the problem. I will try it in Firefox and in IE and report back.

    Thanks for that.

    No scroll bar at bottom of page (when I just now checked while using Chrome).


    Just tried IE and Firefox (very recent versions of each). Same problems. No scroll bar on bottom in either.

    If I click on the edit button or the new post button near the top of the screen, there is no way to save or publish.

    If I click on Pages, near the left of the screen, and then select Add New, then there *is* a publish button.

    But if I click on Posts, also near the left of the screen, and then select Add New, there is not a publish button.


    Correction: there is a bar at the bottom of the screen in IE.


    This problem is really more serious than it might at first appear.

    I literally can’t put up new posts on my own blog. There is apparently no way to publish them.

    Maybe there is a workaround until the problem is resolved?

    Does anyone know how to get around this?

    New posts just won’t publish.



    I had the same problem and unfortunatly I went to the quick post on the draft page where there was a a publish button. It wasnt complete fix to my issue but I was able to publish my post.



    I recommend using a offline blog editor Windows Live Writer is real popular


    Thanks for those suggestions.

    lastory1 — if I may ask, was the problem ever corrected — were you able to get a normal “Publish” button on the blog?

    Also, if anyone knows where I should take this to get it resolved (if that is part of — fixing software bugs), please feel free to post.



    You could contact staff directly at

    Have you tried the Quick Post workaround? Possibly you would then be able to edit posts.


    Thanks. Will try that.



    I had this issue myself last night. The issue was caused by the post being scheduled to be published. After I removed the schedule, the Publish button came back.

The topic ‘No “Publish” Button?’ is closed to new replies.