No tweets on scheduled posts

  • Author
    Posts
  • #410214

    liquidskinn
    Member

    The Publicize tool for Twitter works only on New Posts, but not for scheduled posts. When a scheduled posts is published on its target date and time, no tweets are sent.

    I mean, I don’t mind but it’d be great if this works on published used-to-be-scheduled posts too.

    The blog I need help with is thegiornale.wordpress.com.

    #410397

    raincoaster
    Member

    We can’t investigate without a link to your blog, starting with http.

    #410401

    vinf
    Member

    I tried it this morning but it didn’t seem to work for me either.

    I posted something with LiveWriter, and set the schedule for this morning – article was published but I saw no tweet http://vinf.net (http://vinf.wordpress.com)

    #410405

    raincoaster
    Member

    Thanks for the link. In your case I can confirm that the issue is most likely with the RSS feed. There is a known bug with the RSS feeds of scheduled posts. If you go into the post and edit any aspect of it, turning a period to a comma or anything, then Update, the RSS feed will go out at that time (it does not go out when the scheduled post goes live, though it should). That will presumably kickstart the auto-Tweet.

    #410516

    bobspeakz
    Member

    I’ve used the twitter publicize feature 3 times, with scheduled posts. In all cases the tweet didn’t go when the post was posted.

    In 2 of the 3 cases the twitter box “unchecked” itself. When I updated the post, then the tweet went out…as you’ve described.

    I’d suggest that WP either fix this issue or state that the feature doesn’t work with scheduled posts.

    It’s a great tool, and would be nice if it worked with scheduled posts.

    http://notamystery.com/

    #410525

    ismailimail
    Member

    It doesn’t work. I have reported the same at the news thread. However, support staff is out and my comment is still pending approval.

    I am also trying to identify why it is necessary for them to have a preceding text “posted to wp.com” in front of the tweet. This is very inconvenient as it requires additional step to shoot the blog post over to Twiter (if you wish to delete or change the text). The URL is already pointing to wp.com, so why is there a need to have redundant reference to WP?

    #410526

    lekoning
    Member

    I authorized Twitter today (10/16) and tried to activate it for a post that I had already written, because I really wanted to see how it worked. The box keeps unchecking itself and I see nothing in Twitter. I also normally schedule my posts.

    Is there also a spot where I can permanently customize the message, or do I have to customize the box each time I make a post? It would be nice if there was some kind of customization.

    I like the new feature, and hopefully some of the kinks get worked out.

    #410527

    lekoning
    Member
    #410528

    ismailimail
    Member

    You cannot tweet previously posted blog posts, and you cannot customize the text permanently. The second issue is exactly what I’ve identified above. Perhaps support would listen if enough people see a need to permanently customize the text.

    #410562

    nickmomrik
    Staff

    Currently there is a bug with Twitter Publicize and scheduled posts.

    #410564

    OK. I posted a comment in “Publicize: Twitter” post just yesterday, describing the same problem with the scheduled posts.
    Now I know that, really, there is a small problem with that.
    Thank you for the information

    #410566

    Please, does anyone know if the bug in Publicize Twitter not work with the scheduled posts have been fixed?
    thank you very much ; )

    #410567

    splinister
    Member

    Today the bug I was experiencing with Publicize and scheduled posts got worse.

    Initially, it unchecked the twitter box after the scheduled post went live. To remedy that I had to edit the post, re-check the Twitter box, and press update.

    Today, when I did that the Twitter box unchecked itself again after the post updated. Not tweet was sent. I discovered if I re-edited the tweet, then checked the Twitter box, and updated the post it would work. At this point it’s becoming less than useful to me.

    It’s a pity because this would be a very handy feature if it worked properly.

    Maura
    http://wcos.wordpress.com

    #410581

    jrdskinner
    Member

    Just a note to point out I’m suffering the same bug.

    While I’m here though, I’ll bump the thought that I wouldn’t mind some permanent modifiability in the “custom text”.

    Thanks!

    #410589

    jrdskinner
    Member

    Any updates on this topic? It’s a pretty useful feature for me.

    #410590

    raincoaster
    Member

    No. The RSS bug has been known for about two years now, and no change. Until it’s fixed, it’s unlikely that the Twitter automation can be made to work.

    #410616

    liquidskinn
    Member

    any updates on this one?

    #410617

    raincoaster
    Member

    Uh.

    No. The RSS bug has been known for about two years now, and no change. Until it’s fixed, it’s unlikely that the Twitter automation can be made to work.

    #410618

    timethief
    Member

    This isn’t a solution for what ails but it does the job. I’m a friendfeed member and every post that is published is tweeted. You can set up your friendfeed twitter automatically http://friendfeed.com/about/

    #410619

    raincoaster
    Member

    How does that work? It can’t be RSS-dependent then.

The topic ‘No tweets on scheduled posts’ is closed to new replies.