Not able to add Submenu anymore

  • Author
  • #760787


    In the past I could add a submenu to my list of pages but recently I am unable. I go through the right steps and then when I save the menu the page reverts to its own link and not a submenu. Any ideas?


    The blog I need help with is



    Custom menu troubleshooting – pages and sub-pages
    Check the Pages and sub-pages themselves to see if you have established a Parent page and child page “hierarchical structure” in the page attributes module. Remove if required. Also remove any “order” numbers you have assigned that may conflict with the order you are creating by dropping and dragging in your custom menu. Or simply change them so they are the same order as you establish in the menu. Establish consistency – problem solved.



    tried what you suggested but still not working.
    When I look at the submenus that currently work they do not have a parent page listed. I have tried with and without but unable to recreate a submenu. I have even put the order as 0 or 1 and this does not work.

    I have tried the dragging to create a submenu and it appears to work but when I save the menu it reverts back to normal.



    Have you actually created a custom menu?

    1. You create a custom menu.

    2. You add the Parent pages you want to display and arrange them in the order you want.

    3. Then you add and drop and drag the subpages below the appropriate Parent pages, and when you have everything arranged in the menu that you want you save the menu.

    4. Go to the “theme location” module at upper left on the menu page. Select your custom menu name from the pulldown labeled “primary location.” Click the save button in that module.

    5. Refresh your browser so that it isn’t possibly pulling a cached page, and view see your new menu with Parent pages and dropdowns to sub-pages.



    Yes I have a custom menu.

    I just tried a test:

    I added a page from the list and put in below my home page and then slide it over to be a submenu, then saved and still could not save it as submenu.

    In addition:
    Also I tried to only have a summary of my posts available to view instead of full description but this does not work as well. I am curious if something is up with my site?



    re: drag and drop custom menu issue
    It sounds like a browser issue to me.

    Will you please provide us with some details so we can try to help you?

    1. How are you connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.

    2. Are you using http:// or https:// see

    3.Which browser and version of it are you using?

    4. Have you tried clearing your browser cache and cookies?

    5. Is your browser version up to date? You can upgrade any browser version here.

    6. Do you have third party cookies enabled?

    7. Do you have JavaScript enabled?

    8. Do you have another browser you can try?

    9. You can use this link to see if your Flash is up to date. If it’s not up to date then this is where to download and install the latest version of Flash.

    10. Have you had any recent operating system and/or security program updates?

    The “summary” setting here > Settings > Reading is for your RSS Feed only. To split content in posts you must insert “the more tag“.



    Yes it was a browser issue. Tried a different one and it worked.

    Thanks for your help!



    Hooray! I’m so glad to hear you resolved this. Happy blogging!

The topic ‘Not able to add Submenu anymore’ is closed to new replies.