Need help? Check out our Support site, then

Not Able To Load Blog Or Post New Content

  1. For months now, I'm not able to load my blog, edit pages, or post new content. I have tried several browsers, even different internet servers, and clearing cookies. Everytime I try to load , or click on pages (to edit), new post, or dashboard, I always get -- Google Chrome (Or Internet Explorer/Firefox) Was Not Able To Load This Page. I used to be able to write new posts in the NEW POST tab, but now the publish button just loads, and loads, and loads forever whenener I click on it, but never posts. It is very stressful, and has kept me from updating my blog. I don't know what to do, or what the problem could be. For a year, it worked perfectly fine, and then for the last few months, it has been a total failure. I am able to log in and view the main wordpress page, but I can't click further. Nothing loads! Please help!
    Blog url:

  2. There are currently a lot of problems with the quick post screen. Please use the dashboard instead and please see macmanx's reply in this, as it's relevant:

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.