Not connecting to wordpress.com

  • Author
    Posts
  • #643483

    Installed JetPack on my wordpress install. However when I click connect to wordpress.com in firefox it brings up the save dialog for file admin.php and then when I try in safari I get an error that the server did not respond and to try again later. Please Help.
    Blog url: http://chrispeden.com

    #643704

    macmanx
    Staff

    This normally happens when not enough memory is allotted to PHP.

    If you’re seeing this error either suddenly (no specific task was done to cause the error) or frequently, try deactivating all plugins to rule-out a plugin-specific issue and try switching themes to rule-out a theme-specific issue.

    Otherwise, here are three ways to increase PHP’s memory allocation:

    1. If you can edit or override the system php.ini file, increase the memory limit. For example:

    memory_limit = 256M

    2. If you cannot edit or override the system php.ini file, add this to your .htaccess file:

    php_value memory_limit 256M

    3. If neither of these work, it’s time to ask your hosting provider to temporarily increase PHP’s memory allocation on your account.

    #643711

    macmanx
    Staff

    Here’s another method that might be a bit easier:

    Try adding this to your wp-config.php file:

    define('WP_MEMORY_LIMIT', '256M');

    If that doesn’t help, please try the other three methods.

    #643723

    I tried the htaccess and wp-config methods, and still the same. This is on a dedicated server so resources should not be a problem. Here is the exact error from Safari.

    ==
    Safari can’t open the page “http://chrispeden.com/wp-admin/admin.php?page=jetpack&action=register&_wpnonce=4ff7de1c63” because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again.
    ==

    #643724

    macmanx
    Staff

    What hard limit do you have set via php.ini?

    #643725

    Its set to 64M in my php.ini

    #643730

    I should also mention it appears each time I try to connect jetpack to wordpress.com I get the following in my server log.

    +pid 85361 (httpd), uid 65534: exited on signal 10

    #643745

    macmanx
    Staff

    Can you try temporarily bumping the limit in php.ini to 256M, just be absolutely sure that it’s not a memory issue?

    #643757

    Tried 256M in php.ini and no go, same result.

    #643758

    macmanx
    Staff

    Can you please try disabling all other plugins? Perhaps there’s interference from one of them.

    #643759

    disabled all except jetpack, same results

    #643760

    macmanx
    Staff

    It sounds like your server (Apache?) might be core dumping. What do you have in your server error logs when the connection fails?

    #643761

    I am running Apache 1.3 on FreeBSD

    In my access_log I have this when trying to connect jetpack
    [Thu Jun 30 20:21:42 2011] [notice] child pid 63761 exit signal Bus error (10)
    [Thu Jun 30 20:21:43 2011] [notice] child pid 63969 exit signal Bus error (10)
    [Thu Jun 30 20:21:43 2011] [notice] child pid 63966 exit signal Bus error (10)

    I have this in /var/log/messages
    Jun 30 20:21:14 max kernel: pid 63764 (httpd), uid 65534: exited on signal 10
    Jun 30 20:21:42 max kernel: pid 63761 (httpd), uid 65534: exited on signal 10

    Jun 30 20:21:42 max kernel: pid 63966 (httpd), uid 65534: exited on signal 10
    Jun 30 20:21:43 max kernel: pid 63969 (httpd), uid 65534: exited on signal 10

    Im not sure where else to look.

    #643766

    Please check the php error log, not the access log. Look for anything Jetpack-related.

    The errors above indicate there are problems with your server. Try searching for that error to find some relevant resources and ask your web hosting provider for help to see if there’s anything they can do to help guide you.

    #643771

    Absolutely nothing in the php error log that was jetpack related.

    I don’t know if it matters but this is a cpanel server.

    #643773

    p3ob7o
    Staff

    Please get in touch with your host support or your system administrator, as your Apache server needs to be checked and fixed.

The topic ‘Not connecting to wordpress.com’ is closed to new replies.