Not Receiving Email Notifications for Feedback (Contact Form)

  • Author
    Posts
  • #1040228

    Jetpack’s Contact Form documentation says, “Any legitimate feedback will then be emailed to you, and added to your feedback management area.”

    I am not receiving email notifications when people submit feedback through my contact form. I am also not getting the numbered notifications by the feedback tab in my management area.
    Blog url: http://www.revelintherubble.com/

    The blog I need help with is www.revelintherubble.com.

    #1040345

    macmanx
    Staff

    Ok, so the email are not appearing in the Feedback tab either?

    Which version of Jetpack are you running?

    #1040363

    The emails are appearing in the Feedback management area. That is the only way I know there have been submissions.

    Jetpack 1.8.2

    #1040374

    macmanx
    Staff

    Have you customized the email address that the form should send the emails to?

    If not, it will be sending emails to the address set at Users -> Personal Settings in your Dashboard. Is that address correct?

    #1040494

    No, I have not customized the email address that the form should send email notifications to.

    My user address is correct. It is the address my Jetpack Comments notifications are sent to.

    #1040572

    macmanx
    Staff

    Ok, would you please try changing that email address to something else, to see if the new email address has the same trouble?

    #1040591

    Should I use an email address on a different server? In other words, I’m using a gmail address. Should it be a non-gmail address?

    #1040593

    Yes, absolutely.

    #1040594

    I changed my WordPress.org user email to a @tampabay.rr.com address.

    The same issue persists. Two test contact forms were submitted, one by me and one by my husband. I am still not not receiving the email notifications.

    However, the two test contact forms do appear in the feedback management area (but with no visual indicator in the dashboard).

    Comment submissions continue to work properly. I receive email notifications, a visual indicator in the dashboard, and the form appears in the comments management area.

    #1040609

    The relevant screen in your blog with Jetpack is actually in Users -> All Users. I’m sorry about that!

    However, the two test contact forms do appear in the feedback management area (but with no visual indicator in the dashboard).

    The Feedbacks section in your dashboard won’t display a visual indicator when you receive a new feedback message through your contact form.

    As James said earlier, when you don’t specify an email address for a contact form, it’ll be sent to the email address of the post author.

    So, can you double–check that the email address in Users -> All Users is correct (and that the emails aren’t in the spam/junk folder), then try the contact form once more?

    #1040610

    Hi Bryan,

    >>The relevant screen in your blog with Jetpack is actually in Users -> All Users. I’m sorry about that!<<

    Yes, I figured that out. Thanks!

    >>So, can you double–check that the email address in Users -> All Users is correct (and that the emails aren’t in the spam/junk folder), then try the contact form once more? <<

    Yes, I’ve confirmed that it is correct.

    I check my spam/junk folder daily and the emails are not going there.

    I’ve tested and retested.

    Today I tried adding a customized email to the form, using the advanced tab at the top of the config screen.

    The same issue persists.

    #1040611

    macmanx
    Staff

    Sorry again for the trouble, and thanks for confirming those.

    We’re looking into this.

    #1040632

    Hi maryfairchild,

    Thanks for your patience. We’ve just released Jetpack 1.8.3. Can you upgrade to that in your dashboard and test your contact form again?

    #1040636

    The upgrade was successful. I am now getting email notifications, however, with two oddities.

    1. This code appears at the top of the page after the contact form is submitted/sent:
    Warning: extract() expects parameter 1 to be array, boolean given in /home/usernameremovedhere/revelintherubble.com/wp-includes/pluggable.php on line 216

    http://screencast.com/t/ziCvXTEb

    2. If I submit a contact form while logged into WordPress, I get a screen that looks like this:

    http://screencast.com/t/3wvxiqDoqm8j

    #1040637

    To see if there’s a theme incompatibility, can you try temporarily switching to a default theme (like Twenty Eleven or Twenty Twelve) to see if you get the same result?

    Also, are you using any of the plugins mentioned here?

    http://jetpack.me/troubleshooting/known-issues/

    #1040642

    I’m sorry, but I’m not comfortable switching themes.

    No, I’m not using any of those plugins.

    #1040643

    Okay, can you try deactivating all plugins (except Jetpack), then reactivate your plugins one at a time — while testing the contact form in between — until you see the error appear again?

    #1040646

    I hadn’t had time to test the plugins yet, but today I saw there was an update for Jetpack. So, after installing the update, I decided to test my contact form, hoping the update had resolved the error issues.

    Unfortunately, here are the results:

    Whether I’m logged in to WordPress or not, I get this error now after submitting a contact form:

    http://screencast.com/t/qD9G06ZXawj

    And the email notifications have quit working again. :-/

    I will attempt to test each of my plugins next.

    If this continues I will probably resort to a different contact form.

    #1040647

    The plugin causing the error message is Wysija Newsletters:

    http://www.wysija.com/

    However, the email notifications no longer work as well (and this was the original issue).

    Now what?

    #1040648

    I need to give you a bit more information, and it’s very interesting.

    I just discovered that with the Wysija Plugin re-activated, I DO GET the email notifications.

    But with every prior test, as I re-activated each plugin one by one, and tested the form in between, I did NOT receive email notifications.

    So, I only get the email notifications of a contact form when the Wysija Plugin is active. But then I also get the error screen (http://screencast.com/t/qD9G06ZXawj) upon submitting the form.

    Make sense?

The topic ‘Not Receiving Email Notifications for Feedback (Contact Form)’ is closed to new replies.