Not Working – Limit Number of Posts per Page

  • Author
    Posts
  • #837833

    virtualpaul
    Member

    When I go to SETTING > READING and change the number of post per page, I can change the number to 1 or 2 but it still puts more on the first page?? I am using 2010 theme. Much thanks for any help!!

    The blog I need help with is cheapandeasymeals.wordpress.com.

    #838015

    timethief
    Member

    Your blog is private and I cannot see which theme you are using on it. You could be using one of the themes which Staff have introduced “infinite” scrolling on (Coraline, Pilcrow, Twenty Eleven and Twenty Ten as far as I know).

    If you go to Appearance > Widgets and place one empty text widget in any footer area for widgets, then fo to this page > Settings Reading there will be an option to disable infinite scroll. When you disable it you will regain control over how many posts appear on the main page for posts on your blog.
    https://en.forums.wordpress.com/topic/to-infinity?replies=137

    #838035

    virtualpaul
    Member

    Thank you so much Timethief! I worked like magic—perfect!!!!

    #838038

    timethief
    Member

    Yes! I’m so glad to hear you resolved this. Happy blogging! :)

    #838198

    antbikemike
    Member

    I am trying to follow these instructions, but I am lost at: “Place one empty text widget”

    What is a “Empty text Widget”?

    Sorry for the stupid question…I just want my blog to work and not have to go through this :(

    #838199

    timethief
    Member

    text widget
    > Appearance > Widgets
    locate a footer widget area
    locate a text widget in available widgets box
    place the text widget in the footer widget area box
    click text widget to open it
    do not add a title or any content
    click “save” inside the widget and “close”

    Go to Settings > Reading
    locate and select the option to disable infinite scroll
    “save changes”

    #838200

    antbikemike
    Member

    Thanks,

    I was able to understand and followed your instructions, but there is no section on the Setting>Reading page that says ‘Infinite Scroll”?

    #838201

    timethief
    Member

    I just tried this on my test blog using Twenty Ten. The Reading page did not display an option to disable infinite scroll as it did when I previously tried this right after it was implemented on the first two themes. instead I set up the empty text widget and then noted the infitie scroll was gone, and instead this link appeared at the bottom on my running page for posts “load more posts”.

    #838202

    antbikemike
    Member

    I am not sure what this means?

    I keep searching for a way to make the infinite scroll to stop, but just can not get rid of it :(

    I guess I can not complain about something I am using for free. Maybe I should start paying for wordpress, so I can format they way I want?

    #838203

    raincoaster
    Member

    Go to your Dashboard->Appearance->Widgets and you’ll see a place for Footer widgets. Drag any widget into that. Wait for the change to Save, then you can disable infinite scroll. You have a widget there?

    #838204

    antbikemike
    Member

    Got it…finally! Thank you all very, very much :)

The topic ‘Not Working – Limit Number of Posts per Page’ is closed to new replies.