Nothing happens when importing a posterous blog

  • Author
  • #1138482

    Hi! I’m trying to use the posterous import tool to move my things over to But since I started (36 hrs ago) nothing have happened. It just says “processing” and nothing has been imported so far, according to the importer status.

    Could someone help me out? I have several other posterous blogs which I want to import….

    The blog I need help with is



    Hello there,
    I tagged this thread for Staff help with your import. Please subscribe to it so you are notified when they respond.


    Thanks, timethief!



    I reset the importer for you – could you please try again and let me know if you run into any issues?


    Thanks Jenia – I just started it again. I’ll let you know.



    I see that 536 posts got imported. Checking in to see if you need any further assistance :)


    Jenia, thanks for checking in. Everything worked just fine!
    Now I´ve decided to export it further to a self-hosted WP site. Having problems with that instead. But I guess I’ll have to terrorize the forums with that sort of comments…. ;)

    Thanks for helping me out



    Thanks for letting me know and good luck ;)


    Hi! Now I’m having the same problems with importing another posterous blog to
    Nothing has happended for three days, since i started the import. Would it be possible to reset the importer…. Jenia :)





    Hi Martin, I don’t see a record of an attempted Posterous import since the last one you did. Howdy,

    Could you please download your Posterous content and then try importing from the backup file? Here are the Posterous instructions on how to download a backup:

    Once you’ve downloaded your zip file, unzip it and look for the WordPress export file (WXR). Next, upload that file via the WordPress importer (not the Posterous importer) under Tools > Import > WordPress.

    If you run into any issues or need further assistance, please let me know!


    Thanks, I did not think of that. I have previously tried to import a dowloaded backup on a self-hosted WP-site, but it didn’t work out (said that the wxr-file was corrupt and the posterous support is a bit…. unexisting). But the importer in seem to work fine. I’ll get back to you if it doesn’t work out. Thanks!


    Hi there! I’m having the same problem trying to import post form posterous to wp, like 40 hours ago, and It only says PROCESSING! Can I get some help too! I have posted a topic in this forum but no luck at all.


    My blog is


    Jenia, It seemed to work with the wordpress import, got an E-mail and all. But nothing is imported. Can’t see any posts or media.

    Arandasoft 2012, did you try the procedure Jenia told me to try? Or did you use the posterous importer?



    I used the posterous importer, as I’m planning to follow exactly your process of importing to any blog and then export content as XML to another wordpress location. But I’ve been waiting since Mondy morning but nothing.

    I already sent the back up request, so hope it works, otherwisa I don’t have idea of how to make this possible!


    Jenia, I also tried creating a fresh blog and doing a new WP import from the posterous backup file. Same result- processing for 30 minutes, an email saying import is complete but nothing is imported. Any thoughts?




    Hi Martin, I sent you a private email so that we can look at your Posterous backup file and sort it out for you. I’m going to close this thread, please reply to my email whenever convenient.



    arandasoft2012: I sent you a followup email too, please respond whenever convenient!

The topic ‘Nothing happens when importing a posterous blog’ is closed to new replies.