Number of posts on front page not changing

  • Author
    Posts
  • #844486

    Regardless of what number I set the number of posts to be (in settings>reading), the posts just scroll on and on. I even set the number of posts to “1” (one), and all of them are still appearing.

    Right now I have it set at:

    Blog pages show at most [4] posts,

    but I think there must be at least 20 showing.

    I just changed themes from Quentin to Coraline, but I don’t see that that would make any difference. I only want five or six posts per page. This endless scrolling is annoying.

    Thanks for your help!

    The blog I need help with is apostrophistica.com.

    #844638

    raincoaster
    Member

    Try a forum search for “infinite scroll” and you’ll see what’s wrong and how to fix it.

    #844639

    Thanks, raincoaster! Didn’t know the right search term. :-)

    #844642

    raincoaster
    Member

    No worries, it can be hard to find the right term, but hundreds and thousands of people have been through this exact issue.

    #844643

    timethief
    Member
    #844646

    Yup, I found you, timethief! And the empty footer widget fixed it. So glad I came here & asked before I started tearing my hair out!

    #844650

    timethief
    Member

    Never ever tear you hair out! Get up go outside and pace while reciting the mantra “it’s only a blog” for at least 10 minutes before reboot your computer.

    #844651

    That’s excellent advice! :)

    #844758

    miketayse
    Member

    I noticed the same thing. I have it set to display 2 posts, but It keeps trying to load everything! It takes forever for it to load now. I guess I need to do some reading. I did nothing, the settings says 2 posts,you would think it would work. It did previously. Now it does not. I don’t get it.

    #844759

    @miketayse:
    Create an empty footer widget (just drag a text widget over to your first footer widget area), then go back to the reading settings page and you should be able to untick a new box that says “infinite scroll.”

    This has got to be one of the dumbest ideas I’ve seen in blogging — not the infinite scroll per se, since for some blogs, it might be okay — but the implementation of it. There should always be an opt out without having to create a fake footer widget to get the opt out option to appear, and any blog that’s designed with a footer widget shouldn’t have an infinite scroll, only blogs that don’t use them. What is the point of a footer widget when the blog just goes on and on and on. (Which I think looks pretty amateurish, and except in twitterish themes, doesn’t seem practical. I think that people who keep scrolling aren’t necessarily reading the posts they’re scrolling by, they’re looking for the danged end of the page!)

    #844761

    miketayse
    Member

    Thanks! Remember, I’m new, I don’t want to sound like an idiot. I went to widget area, found a blank text widget, where is the footer area, I don’t see anything labeled the footer area? I’m going back. I went to the forums and typed in footer, got nothing usable.

    #844762

    timethief
    Member

    @miketayse
    MistyLook is the theme your are using and it does not have footer widgets > Appearance > Widgets.

    Go here > Settings > Reading and locate
    Blog pages show at most __ posts
    enter the number you want ie. 2
    click “save changes”

    #844763

    justpi
    Member

    Sorry TT, WP added infinite scrolling to MistyLook…

    #844764

    timethief
    Member

    @miketayse
    I was not aware that the MistyLook theme now has “infinite scroll” implemented too.
    Please see here > https://en.forums.wordpress.com/topic/only-display-one-post?replies=17#post-840462

    #844765

    miketayse
    Member

    Yay! My blog is enabled!

    #844766

    timethief
    Member

    @miketayse
    Hello again,
    I don’t mean to be “thick” but what does that mean? Do you have control over the number of posts appearing on your blog using MistyLook or not?

The topic ‘Number of posts on front page not changing’ is closed to new replies.