Number of posts on home page

  • Author
    Posts
  • #833278

    kimartyac
    Member

    Good evening!

    Ideally, I would like the three latest posts to show on the home page.

    Where can I go to change this? Right now there are several posts listed there.

    Thank you.

    Kim

    The blog I need help with is friendsofdcwc.wordpress.com.

    #833454

    timethief
    Member

    We set the number of posts we wish to display on the front page here > Settings Reading
    Blog pages show at most __ posts

    #833455

    raincoaster
    Member

    You can change it under Settings->General unless you’re using one of the themes with Infinite Scroll.

    #833457

    raincoaster
    Member

    Spoke too soon. I meant Settings->Reading.

    #833494

    kimartyac
    Member

    That’s what’s confusing me.

    When I go to Settings/Reading/Blog pages show at most – it says 2.

    There are 7 on the home page of http://www.friendsofdcwc.org/.

    Any other ideas?

    Kim

    #833497

    raincoaster
    Member

    That is because you are indeed using one of the themes with infinite scroll. You can disable that under Dashboard->Settings->Reading https://en.forums.wordpress.com/topic/infinite-scroll-do-we-get-an-opt-out-and-will-this-apply-to-other-themes/page/5?replies=138#post-817272

    #833504

    kimartyac
    Member

    I see. There is no option to disable that that I can see. What am I looking for?

    For now, my work-around will be to make previous posts ‘private.’ Not ideal, but it does the job.

    Kim

    #833506

    timethief
    Member

    @kimartyac
    Don’t make you posts privatw. If you place one empty text widget in any footer area on your blog and refresh that Reading page, then you will find you will have the option to disable infinite scroll, and regain control over how many posts display on the front page of your blog.

    . If you’re using footer widgets to display content in your blog, you can now disable infinite scrolling by visiting your Reading settings, in your dashboard. We’re still working on improving the reading experience with infinite scroll, including how well it integrates with your themes and customizations. https://en.forums.wordpress.com/topic/to-infinity/page/5?replies=137#post-817186

    #833529

    kimartyac
    Member

    Got it. I fixed it.

    Thank you to you both!

    Kim

    #833530

    timethief
    Member

    Woo hoo! I see that you did. Happy blogging! :)

    #833534

    kimartyac
    Member

    I’m tryin. :)

    #833554

    timethief
    Member

    You’re doing well – hang in there. :)

    #833557

    raincoaster
    Member

    Read the link I gave you; it shows you how to disable it.

The topic ‘Number of posts on home page’ is closed to new replies.