Number of posts per page not working

  • Author
    Posts
  • #650388

    immrfabulous
    Member

    I am changing the number of posts per page visible to my readers but the changes are not displaying. For instance, if I change the reading setting to 50, 50 posts will display in order from new to old, but after, on the same page it will go back to my first post and show them all from oldest to newest.
    Blog url: http://immrfabulous.wordpress.com/

    #650493

    hanni
    Member

    OK! This is happening because you seem to have set most of your posts to be sticky posts and these, by nature, override the post per page setting as you’re telling WordPress that these posts are important and therefore to display them regardless of any other settings.

    You can unstick these posts from Posts in your dashboard by hovering over your post titles one by one, clicking “Quick Edit” and removing sticky status.

    #650679

    immrfabulous
    Member

    100% correct! Thanks for explaining that, I made them sticky so they have a light colored box around each post so they seperated… I had know idea thats what sticky ment.
    I took most of the sticky off, is there a way to have the post seperated so they don’t run together?

    #650689

    macmanx
    Staff

    There should be some visual separation between posts when they aren’t sticky.

    If not, you might want to try a different theme that has clearer separation, like Twenty Eleven.

The topic ‘Number of posts per page not working’ is closed to new replies.