Old blog icon lingering

  • Author
    Posts
  • #1943304

    eirewitch
    Member

    I have deleted the image formerly used as a blog icon from my site (including media gallery). I have uploaded a new one. When I now post a link from my blog into a Facebook status update the old blog icon image appears in the link (like in the third post in page below).

    It also continues to appear in old shares on Facebook, the new image has not linked in to update these. I have tried clearing the cache. This can be seen in the third post on this page: https://www.facebook.com/phoenixhandfasting

    How can I stop both of these? Thanks.

    The blog I need help with is phoenixhandfastingdublin.wordpress.com.

    #1943410

    raincoaster
    Member

    You need to clear the Facebook cache. http://umairj.com/146/how-to-clear-facebook-shares-cache/ The change is not retroactive.

    #1943524

    eirewitch
    Member

    Thanks raincoaster, but I have tried the above on foot of your suggestion and the old image still shows when posting new links.

    #1943525

    timethief
    Member

    Facebook may update its cache faster if you use the debugger
    https://developers.facebook.com/tools/debug

    #1943527

    eirewitch
    Member

    Thanks timethief. I’ve tried this already; it was one of the three methods in the above article suggested by raincoaster.

    #1943528

    timethief
    Member

    Sorry I wasn’t helpful. I’ll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1943533

    rachelmcr
    Staff

    Hi there,

    Unfortunately, this is an issue with Facebook’s cache and isn’t something we can fix. If you check your posts in that Facebook debugger, you’ll see that the image we’re sending Facebook is this one:

    http://1.gravatar.com/blavatar/b2d89d0e3be611ffd7e7e19def4e77c7?s=200

    You can check that by clicking on the image next to “og:image” in the Facebook debugger. However, Facebook has cached your blog’s old image, so it’s displaying that one instead. You’ll need to wait for Facebook to update its cache in this case.

    #1943561

    eirewitch
    Member

    Thanks rachelmcr.

The topic ‘Old blog icon lingering’ is closed to new replies.