older posts button not working

  • Author
    Posts
  • #2926603

    brunhub
    Member

    I have a blog category, travel impressions, that has 9 posts in it. When I click on the link in my menu for ‘travel impressions’, only 5 posts load, with an ‘older posts’ button. When I click on the button nothing happens except it disappears.

    Why is this button no longer working?

    The blog I need help with is brunospov.wordpress.com.

    #2926797

    musicdoc1
    Member

    Hi,

    The same thing happened when I clicked on the ‘older posts’ button on your ‘travel impressions’ category page. I’ve called for staff attention to the topic. Please wait for staff to respond.

    #2926818

    Hi brunhub,

    When I click on the link in my menu for ‘travel impressions’, only 5 posts load, with an ‘older posts’ button.

    The number of posts being displayed on that page is set in your Reading settings:

    https://brunospov.wordpress.com/wp-admin/options-reading.php

    You’ll notice ‘Blog pages show at most’ is currently set to 5.

    When I click on the button nothing happens except it disappears.

    As you say, the ‘Older posts’ button should display more posts in that category. The fact that it doesn’t suggests there is a bug in the theme.

    I’ll create a bug report and keep you posted.

    Thanks for tagging this musicdoc1!

    #2926834

    brunhub
    Member

    Thank you, that fixed it. Bruno

    #2926863

    Hi Bruno,

    Good to hear, thanks for letting me know :)

    #2926869

    musicdoc1
    Member

    @gemmacevans,

    On a test site with the Oxygen theme activated, I find that a category page displays all posts in that category regardless of the “Blog pages show at most” setting at Reading Settings. There are six posts with the tested category assigned to them. “Blog pages show at most” settings of 1,2,and 5 were tested, all producing the same result: all six posts display in the category page.

    I wonder if this might be due to work on the theme relevant to the bug report you created.

    #2926877

    Thanks for this musicdoc1!

    #2926880

    musicdoc1
    Member

    You’re welcome!

    #2926882

    [Not sure if that’s relevant here, but I have the same problem: https://en.forums.wordpress.com/topic/twentyseventeen-older-posts-button-broken-on-posts-page. The pagination used to work and look well, the button is new (I think), but not working.]

    #2926883

    brunhub
    Member

    See above from gemmacevans.

    #2926884

    musicdoc1
    Member

    @manuschwendener,

    The issue that you reported in the topic Twentyseventeen: ‘older posts’ button broken on Posts Page is similar to the one reported in this topic, but probably unrelated, since it’s on a different theme. I’ve added a “modlook” tag to that topic to call for staff attention. Staff might be shorthanded on the weekend, so it might not be responded to until Monday morning (US time).

    I encountered the same trouble displaying page 2 of the posts page of your site that you reported in the other topic.

    #2926885

    Thank you :-)

    #2926886

    musicdoc1
    Member

    You’re welcome : – )

    #2926889

    Hi brunhub,

    I’m just doing some testing and have a few questions for you.

    • Did the problem only start recently?
    • Did you make any changes to your site before the older posts button stopped working?
    • Would you mind removing the Goodreads widget while I test? I’ll let you know when I’ve finished and you can add it back again.

    Thanks!

    #2926890

    brunhub
    Member

    Hi gemmacevans, I’ve fixed the problem with your solution. I just increased the number of displays in the reading setting. Not sure what a Goodreads widget is.. B

    #2926891

    musicdoc1
    Member

    @brunhub,
    Increasing the number at Reading Settings may temporarily work, but it doesn’t really address or resolve the issue. For example, if you were to increase the “blog pages show at most” setting to 10, then once you’d reached 11 posts in the ‘travel impressions’ category, the same error would occur.

    #2926892

    Hi brunhub,

    I just wanted to let you know that we’ve been doing some further testing on this issue.

    I’ll let you know when I have an update. In the meantime, thanks for your patience.

    Speak to you soon.

    #2926893

    Hi brunhub,

    We’ve found the bug causing this issue. There are 9 posts in the Travel Impressions category — 3 of which are ‘sticky posts’. Clicking the older posts button only displays a maximum of 6 posts for that category because the theme isn’t including the sticky posts.

    If you add a featured image to the sticky posts, they should appear in the featured slider (which supports up to 6 posts).

    We’ll work on a fix for this and I’ll keep you posted.

The topic ‘older posts button not working’ is closed to new replies.