Only Display One Post

  • Author
    Posts
  • #844005

    itwasjuly
    Member

    I’m very new to wordpress. I have just a basic site and standard theme (twenty ten) What I’m trying to accomplish is having my “home” page show only 1 recent post, while my archives/blog pages show all the rest. I’ve read a lot about this, but the answer is always a coding solution, and I manage my wordpress directly from wordpress.com. I’ve always gone to Settings>Reading>Posts Per Blog – but all that changes is the amount of posts showing up in my archives and not on my home page. PLEASE HELP if there is something I’m missing or a way to change this. Thank you.

    The blog I need help with is itwasjuly.wordpress.com.

    #844140

    hnsaifi
    Member
    #844142

    timethief
    Member

    Staff introduced infinite scroll to some themes (wTenty Ten, Twenty Eeleven, Coraline, Pilcrow) . If you place an empty text widget in any footer area for widgets an option to disable infinite scroll will appear on this page > Settings > Reading. After you disable it click “save changes” and that will result in the display of the number of posts you select to display on that same Reading page.
    https://en.forums.wordpress.com/topic/to-infinity/page/5?replies=137#post-817186

    #844151

    itwasjuly
    Member

    hnsaifi > You’re link didn’t work, could you try reposting for me?

    timethief> Thank you that has helped. The front page looks much cleaner. My only concern now is, if someone goes to search from the archives they too only get one post per page. Is there any way around that? Thank you again for the response.

    #844161

    hnsaifi
    Member
    #844164

    timethief
    Member

    @itwasjuly
    Please follow the instructions I posted. They work. I know they work as I have tested them in all themes I mentioned above.

    #844177

    itwasjuly
    Member

    @timethief you’re instructions worked perfectly for fixing my “home” page. I still must be doing something wrong however, because the archives page is also still only showing 1 post per page. I’ve places a blank txt box in the footer area, turned off infinity roll, and changes post per blog to 1. This worked for the home page, but it also changed the archives page as well. Sorry to be redundant. I’m sure it’s something on my end. You can see what I’m talking about here

    #844181

    timethief
    Member

    I still must be doing something wrong however, because the archives page is also still only showing 1 post per page.

    In the majority of themes, posts on category or other archive pages show up just as they do on the main posts page. But in some themes only the beginnings of posts are shown, and in a few themes you only get titles or thumbnails.
    http://wpbtips.wordpress.com/2009/03/25/full-posts-in-archive-pages/

    See here for using the excerpt box (Category/Archive pages only) > http://wpbtips.wordpress.com/2009/03/25/the-excerpt-function/

    #844208

    justpi
    Member

    The number-of-posts-per-page setting applies to all dynamic pages: main posts page as well as category and other archive pages.

    If you want one full post on your blog front but several on archive pages, you can switch to Twenty Eleven and use the showcase template page as your front; details here:
    http://wpbtips.wordpress.com/2011/05/04/workings-of-duster/
    Similar special template page available in Splendio and Nuntius.
    Or you can switch to The Morning After; details here:
    http://wpbtips.wordpress.com/2011/06/02/the-morning-after/

    #844310

    Thank you for the explanation about the infinite scroll, timethief. I will go put in an empty footer widget now. I was flummoxed. I had played with Coraline in the past on test blogs, and it never did this infinite scrolling.

    I don’t know why that would be considered a good idea. At least as a default.

    Thanks again!

    #844311

    timethief
    Member

    @apostrophistica
    This is a relatively new change Staff has made recently to only some themes. It seems that the the intent is to have “infinite scroll” on all themes that are suitably constructed for it to operate on.

    #844312

    @timethief: IMHO, it might not be a bad idea if the powers that be put some kind of little explanation of this feature on the “reading” settings page.

    Thanks again for the help. It solved the problem perfectly. (I just used an empty text widget. I may eventually use the footer area for something, but since I just converted it over from Quentin, I haven’t done much with the layout yet.)

    #844313

    timethief
    Member

    IMHO, it might not be a bad idea if the powers that be put some kind of little explanation of this feature on the “reading” settings page.

    I do agree with you on that. Note that Staff have yet to announce in the official WordPress.com blog that “infinite scroll” exists and has been implemented on sone themes.

    #844332

    miketayse
    Member

    This probably sounds stupid. I’m new.

    So the new feature, if I’m understanding this correctly, is intended for all my pages to load(this takes awhile, I’m an art teacher, lots of photos) on the home page so readers don’t have to click through.

    But I can add a widget to the footer area. Like I said, I’m new to WordPress, using the freebie stuff to try things out, so I’m not sure how to do this.

    I went to appearance, saw header, saw background, etc., no footer. Ok. Back to forums. I just want it to load two posts at one time, so it can load reasonably quickly. It used to, now it does not. I have a couple of blogger sites, pretty much the same kind of thing, arbitrary changes to improve things. Does anybody really need all their posts to load up on the front page? What am I missing? How would you utilize this feature?

    #844333

    timethief
    Member

    Hi there,
    The answer in this thread given to itwasjuly and apostrophistica were theme specific. They have themes with “infirte scroll” and you do not. You are using a different theme ie. MistyLook and there are no footer widgets in that theme.
    Go here > Settings > Reading and locate
    Blog pages show at most __ posts
    enter the number you want ie. 2
    click “save changes”

    #844334

    justpi
    Member

    @TT: Unfortunately WP added infinite scrolling to MistyLook.

    #844335

    timethief
    Member

    @justpi
    Thanks for clueing me in to that. As there are not footer widgets it appears the best advice we can offer the users of MistyLook, who wish to be able to control the numbber of posts displaying on the front page of their blogs like miketayse does is to switch to a theme with footer widgets.

    @miketayse
    Please note what justpi and I have been discussing.

    #844336

    Boy, that sucks. Are they going to turn every blog w/o footer widgets into endlessly scrolling messes? I wonder how many people actually *like* that feature. It certainly seems to go counter to most everything I’ve heard & agreed with about making a user-friendly blog. Personally, I hate sites that go on and on and on and just keep scrolling. I can’t imagine trying to read a news site like that.

    #844337

    timethief
    Member

    I discern from this thread https://en.forums.wordpress.com/topic/to-infinity?replies=137 and Matt’s (co-founder of WordPress.com) comments in it that this will be a site waide change. The plan is to implement ‘infinite scroll” on all themes wherein the structure allows it and that means it will affect all themes except those which are not accomdating like DePo Masthead.

    #844338

    miketayse
    Member

    So, It will now continue to load all the posts at once, nothing I can do? Yay me! Who can I send a thank you card to for such an awesome upgrade.

    I’ve never switched templates, any suggestions as to something that would give me basically the same look, useability, etc.?

    I certainly appreciate all the help!

The topic ‘Only Display One Post’ is closed to new replies.