"Only secure content is displayed" in admin pages

  • Author
    Posts
  • #1230003

    oxmark
    Member

    I keep getting this message each and every time I am logged in, if not, it is OK, it is really annoying.

    Reading the the forums, I have disabled all IE extensions, set admin to https, http: etc logged in out and stopped and restarted, but NOTHING will make it go away. Going through IE settings nothing looks obvisously wrong.

    Could it have something to do with DNS as I have mappings to :

    http://www.headingtonheritage.org, org.uk, and the internal wordpress one?

    Many thanks

    The blog I need help with is headingtonheritage.org.

    #1230217

    raincoaster
    Member

    No, it should not. It sounds like there’s something in your browser that is freaking out; do you have any security add-ons?

    #1230238

    oxmark
    Member

    Running Norton along with most of the planet – disabled everything which all looked very normal, although I did not see Norton in the list.

    It also happened on another blog I was reading, very well known and useful: (WordPress Tips)

    It is definitely pointing at my browser, although it is standard IE 9 64 bit.

    http://wp.me/PtD4e-1g8

    Thanks for your reply

    #1230284

    oxmark
    Member

    Progress – but now I need WordPress help.

    1/ The error occurs on all pages only when I am logged in, admin pages or normal ones a visitor would see.

    2/ If I say “show insecure” yes, then I see the footer widgets, if no, they disappear, ie they are “insecure”

    Looking at Fiddler output, I noticed some 443 (HTTPS) traffic to Gravatar – I removed the Gravatar widget from the second footer and now the message has gone. It did come back once, possibly caching.

    There is a bug here, I would guess the widget is opening a secure connection over https and then calling a http: link, there is lots of stuff about this on the Windows web site.

    BUG REPORT – seems the Gravatar Widget has one? My findings are not 100%, it is solved, I think, so I am happy.

    #1230310

    timethief
    Member

    Thanks for letting us know this is resolved for you temporarily. I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1230313

    macmanx
    Staff

    Please make sure that you’re visiting http://headingtonheritage.org/ and not https://headingtonheritage.org/

    It’s not necessary to browse via HTTPS on the front end.

    If you’re seeing the warning in your Dashboard too, you probably have a corrupt browser extensions trying to inject insecure content, like ads.

    #1230314

    timethief
    Member

    Aha! That was my guess too and now it’s confirmed. Bookmarked!

    #1230323

    oxmark
    Member

    This has come up on lots of previous topics, and I have tried:

    Disabling all extensions
    Changing security settings to “show mixed content”
    Placed in trusted zone

    Restarted, logged in out.

    No, I am not using https://, set the admin option to off too.

    Even drafted all my posts in case there was a post with https: in which should not be an issue anyway.

    These are all solutions I tried before raising the topic.

    I get the same on the Word Press Tips blog (heartfelt thanks, very useful)

    http://wp.me/PtD4e-1g8

    #1230329

    macmanx
    Staff

    Would you please check in a different browser, like Chrome or Firefox?

    http://browsehappy.com/

The topic ‘"Only secure content is displayed" in admin pages’ is closed to new replies.