Option to set where posts appear has disappeared!

  • Author
    Posts
  • #982754

    wrethink
    Member

    I have set up a static page for my new blog wrethink.wordpress.com. Now, I want to set up a new page for my “blog” and the options where I designate the location of my home page and posts have completely disappeared from where they belong: options–>reading. What now?
    Blog url: http://wrethink.wordpress.com/

    The blog I need help with is wrethink.wordpress.com.

    #982881

    timethief
    Member

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. If you do not want all the posts to show on the front page, then you can create a static front page “Welcome” for your site and a “Blog” page for posts.

    Choice 1 static front page
    Choice 2 running page for all posts on front page

    Which do you choose? It’s one or the other. If you choose a static front page then you have to create two pages as I said above. After you do that you go to > Settings > Reading and make the designation change and click “save changes”. http://en.support.wordpress.com/pages/front-page/

    If you set a static front page but fail to create a page for blogs to appear on and designate it here > Settings > Reading then that could be the cause of your issue.

    #982952

    wrethink
    Member

    I am aware of this setting — and actually DID set up a static front page. Can’t show you my site because it’s private. The problem I am experiencing is that — even though your instructions are correct — the Settings>Reading panel NO LONGER INCLUDES the settings for static front page and where posts reside.

    Further, I have created two pages on my site — Home and Blog — but on my Dashboard the Pages count is zero. Maybe this is also a contributor to the problem?

    Do I need to contact WordPress tech support?

    #982959

    wrethink
    Member

    Figured it out! Because both of the pages on my site — Home and Blog — plus my one blog post were all set to Private, the settings for static page and blog locations disappeared from the Settings>Reading menu. I turned everything to Public, the location settings re-appeared, and I was able to get everything working they way I want it to.

    I then re-set the Blog page to private, it vanished from the home page the the navigation settings at Settings>Reading again disappeared. So if someone is having a problem with the navigation setting, ask them whether their pages are private. They need to set their pages to public to have this work properly.

    #982960

    timethief
    Member

    Thanks. :) I was just about to post the following:
    Custom Menu Troubleshooting – My Pages aren’t appearing
    They must be public pages – not private.
    Public – The page will be visible to everyone.
    Protected – The page is protected with a password you set. Only people who have the password can view a protected page.
    Private – Pages are only visible to blog Editors and Administrators. Private pages are not visible in Blog Surfer, feeds, or in any search. A page can be private without being password protected.

The topic ‘Option to set where posts appear has disappeared!’ is closed to new replies.