Order of pages

  • Author
    Posts
  • #971365

    Hi,
    I’ve read the posts about this. I do not have pages attributes and I’ve dragged the order of pages in ‘custom menu’ but still they show in the wrong order. What am I doing wrong?
    My theme is ‘brand new day’.
    Thanks

    The blog I need help with is ashtangayoganambour.com.au.

    #971496

    justpi
    Member

    You do have ‘Page Attributes”. If you’re not seeing this module while on the page editor screen, click Screen Options (top right) to enable it. If you set the page order via order numbers in the Page Attributes module, then go to Appearance > Menus and make sure the blank option is selected in the Theme Locations pulldown (so that the theme will display its regular menu).

    If, on the other hand, you set the page order by dragging the items in the custom menu you have created, make sure you select that menu from the Theme Locations pulldown.

    For more on custom menus see here:
    http://wpbtips.wordpress.com/2011/12/19/custom-menus/

    #971516

    ldhltd
    Member

    Hi. I’m using Oxygen. I’ve just created some new pages and was trying to add them to the menu. I’ve allocated sub-pages order numbers and they display correctly in the menu pages selector. I then tried to add the new pages to the existing menu and then use the drag and drop feature to put them in the right order, as I’ve done many times before with this theme and others. However every time I move the cursor over a menu item it jumps, or grabs others and won’t move to the correct place. Clicking on the edit menu item down button does nothing other than demote the menu item even lower, but then it won’t move further. I’ve tried deleting the menu a few times and starting again, but keep having the same problem. My home page now looks a complete mess. Can you help me urgently please. The site is http://www.ldhmarketing.co.uk. Many thanks.

    #971519

    ldhltd
    Member

    Well, posting on here seems to have magical properties as after an hour or getting nowhere, the menu is behaving itself again. This is not the first time I’ve had a problem, though never for more than some minutes, does anyone have any idea what may be causing it?

    Plus, if I could make a suggestion for the number one most helpful improvement WordPress.com could make (and I remain a fan not a critic!) it would be to have a better way of managing menus, so you could select the order by number in the menu area (not on each page) and assign top level and sub-menu items by number not drag and drop, a bit like the widget system in Twenty ten. Thank you.

    #971540

    HI,
    Well I managed to get the page attributes back under ‘edit’ on my home page, however when I did the drop down under parent page, my home page wasn’t there to select. So instead I put a number 1 in the order box, but this just changed my home page from number 3 to number 4 on the homepage.
    I’m confused about Menus and I don’t seem to have a Theme locations option. Under appearance I only have ‘themes’ or ‘theme options’. So how do I find ‘theme locations’?

    #971546

    justpi
    Member

    It’s all explained in the post I already linked to:
    http://wpbtips.wordpress.com/2011/12/19/custom-menus/
    The Theme Locations module is in Appearance > Menus.

    #971642

    Hi Justpi,
    That link you sent me really helped, thanks!
    I deleted exisiting menus and started again.
    I’ve put my pages in the correct order successfully.
    Now to removing “Leave a reply” enter your comments here…… on my Static Home Page. Any ideas?

    #971648

    justpi
    Member

    You’re welcome.
    Your other question has been answered here:
    https://en.forums.wordpress.com/topic/removing-leave-a-reply-on-my-static-homepage?replies=4

The topic ‘Order of pages’ is closed to new replies.