Oulipo, first line capitalised

  • Author
    Posts
  • #527345

    Hi,

    just editing a draft and noticed the opening line of the article is now capitalised, it wasn’t before. I looked at the HTML and couldn’t see a stray tag, I cut it, re-pasted it ‘clean’ and reformatted it, the problem remained.

    I then looked at my homepage and can see that intermittently several other articles that have been published, have the same problem. Should I conclude that’s it’s a bug or, have I pressed the wrong button (I can’t see how). This ‘style change’ appears on all 3 browsers I use.

    Any suggestions?

    cheers

    The blog I need help with is terencegallacher.wordpress.com.

    #527474

    Just to add, I now notice it appears on other wordpress users pages that use Oulipo too. So hope it can be rectified, it’s a great theme.

    #527510

    tudobeleza
    Member

    Yes, I noticed it too and I hope it can be removed or at least made into an option.

    #527535

    I’ve tagged this thread for staff attention, but where are you copying and pasting from? Are you writing the articles from scratch or copy pasting off the internet?

    #527540

    Hi, thanks, I’m writing the articles from scratch, with the visual editor, but I checked the HTML editor and there wasn’t anything wrong with the coding. In any case, other people using the same Oulipo have the same glitch.

    Oulipo has been removed as a theme option under the APPEARANCE > THEMES menu too.

    #527544

    Yeah, I did a view source and did not see tags or anything that would cause this either.

    If staff does not reply to this thread in a few hours, contact them directly at http://en.support.wordpress.com/contact/ .

    #527547

    Many thanks for your help.

    #527548

    You’re welcome and hopefully they get this sorted out for you quickly.

    #527655

    peccamus
    Member

    Same here. If someone knows the CSS to unformat the first line I’ll add it myself

    #527659

    tudobeleza
    Member

    I’m not sure if staff was contacted directly but I will do so now.

    #527660

    Hi Tudobeleza, I did send a message to the staff a few hours ago, no reply as yet.

    I find the problem only applies to the home page, when you click on and read the articles themselves, there is no problem. I have found, and maybe it’s connected, a problem with the spacing around images in articles.

    As I say, hope it can be sorted, it’s a great theme.

    #527661

    lance
    Staff

    Hi all—the first line uppercase text is part of the theme’s design, it’s not a bug. :)

    #527663

    I find it very elegant. But anyway, if someone doesn’t like it, the CSS to remove it is:

    .entry > p:first-child:first-letter, .entry > p:first-child:first-line { font-family: “Lucida Grande”, “Lucida Sans Unicode”, Verdana, sans-serif; font-variant: normal; font-size: 1em; }

    #527664

    tudobeleza
    Member

    So it was a feature that never was implemented or perhaps only implemented for some from the time of its release until now. Got it.

    Basically, I would need to enter that CSS code everytime if I wanted to remove it? Or does that require the CSS Upgrade and it’s a one-time thing?

    #527665

    CSS upgrade only, once only.

    #527674

    tudobeleza
    Member

    With this theme (that I use on all my blogs), I must be penalized financially to remove something that wasn’t there in the first place. Nice!

    Enough on that, I’m just kicking a dead horse. I believe this topic can be closed.

    #527678

    You can get rid of the capitalized first line by wrapping each post in a div as below.

    <div style="text-transform:none;">
    All your post text here.
    </div>

    You would have to do this for each post, but at least it is a solution.

    I have to agree here that before now I had not seen this capitalization of the entire first line on this theme, although it does show on the introductory blog post in the screenshots, and also shows up on the .ORG version at extend/themes at wordpress.ORG.

    Perhaps staff would think about adding the ability to turn the first line capitalization off under theme options?

    #527679

    Of course the above would have to be added in the HTML tab.

    #527680

    @tudobeleza: I can assure you that it was included in the CSS of the theme from the beginning. If there was a bug, the bug was whatever prevented it from showing.

    No-upgrade solutions (in the HTML editor):
    Write your first paragraph this way:
    <div style="font-variant:normal;margin-bottom:2em;">
    Or paste this before the first paragraph:
    <div style="display:none;">-</div>

    #527681

    Sorry, forgot the closing tag in the first option:

    <div style="font-variant:normal;margin-bottom:2em;">
    TEXT HERE
    </div>

The topic ‘Oulipo, first line capitalised’ is closed to new replies.