Oxygen: The god awful Slider. NEED HELP.

  • Author
  • #1038877


    So, i have followed what everyone as written about the Oxygen Slider before, but i just can’t seem to get this working.

    I have made my Page ”Home” the static page, with the page ”Blog” my page posts go to.

    I have then created a ”Post” and clicked ‘feature image’ at the bottom right and added it as a feature image, which is 740px. I then clicked ‘make this post sticky and it will appear on your home page’ and it DOESN’T appear on my Home page? it Just appears on the Page ”Blog”

    Someone please help me!

    The blog I need help with is shrewdtwo.wordpress.com.



    When i STICK A POST, it appears on my Blog page, when i DONT stick a post, it appears on my Front Page.

    Everytime i stick a post, it NEVER appears in the slider!

    I have a 740px width photo, when i go to upload it to WP, it says ”Full Size” – 400px?



    I had similar issues, it worked when I made the images 750 pixels wide



    WordPress won’t let me make the photo 750px though? I’ve edited them beforehand and made them 750px, i put them into wordpress and nothing? nothing works! It won’t let me select the picture bigger then 400px?



    Ok, I had issues with the slider for a long time too, but I finally figured it out. You can check out the results at http://stevelikesmathalot.wordpress.com.

    Here’s how I got things to show up in the slider. Make the home page (or whatever page you want the slider to show up on) your Showcase page. Then when you want a post to show up in the slider, make it sticky. Here’s where things get a little weird, but try to follow this. You click the link that says “Set a Featured Image” and then you are brought to the image upload popup. Select your image, wait for it to upload, and then scroll down to the bottom. Underneath the part where you select the size of your photo, there is a link/button/something that says Use as Featured Image. Click this, and then leave the size alone. In my experience, once you click this button the size does not matter. Save the image, and it should show up in the slider now.

    If this does not work please write again and I’ll get into a little more detail.



    didn’t work for me… just did that T_T


    does not work for me :(



    Ok, let me go through the steps myself once again, to make sure I have it exactly right.

    (1) Only one page (page, not post) will show the slider, so you need to decide which page you want to show it. I will assume you want your home page to show the slider, since that makes the most sense. In your Dashboard, go to Pages/All Pages. This will give you a list of the Pages you currently have on your site. (If you do not have a Page, you must create one in order to use the slider.) Mouse over the Page you want to be your home page, and select the “Quick Edit” option. There will be some drop-down menus that show up: “Parent,” “Template,” and “Status.” In the “Template” menu, select “Showcase Page.” Selecting this as the template tells Oxygen that this is the page you want to show the slider. Click the “Update” button in the corner of “Quick Edit” to make sure your changes are saved. I suspect some of the problems you’re having may be due to not clicking buttons for saving changes you’ve made.

    (2) Now, in your Dashboard, go to Settings/Reading. The first item presented to you will be “Front page displays,” for which you have two options: (i) Your latest posts, (ii) A static page. Select “A static page,” and then in the drop-down labeled “Front page” choose “Home” (or whatever the title of your desired home page is). Scroll to the bottom and click “Save Changes.”

    So far, you have accomplished the following: In (1), you told Oxygen that you want to use the slider, and said which page you wanted that to happen on. In (2), you told your blog to land on that page specifically whenever someone types in or clicks on your URL. (I have not tried doing one without the other, so I don’t know if you can have the slider without setting a static front page. I will assume you don’t want that, though, since the whole point of a slider is to have an attractive main page of your website.)

    (3) Now, you need to set Featured Images. Like I said, the images need to sized on your computer to be exactly 750×380. I think that Oxygen will crop them for you if they are larger, but if they’re smaller nothing will show at all. Anyway, if you want complete control over what shows in your slider, make sure any pictures you want to show up are exactly 750 pixels horizontal and exactly 380 pixels vertical so that nothing gets cropped (or worse, doesn’t show up at all). Once you have your images sized to these specifications, go to your Dashboard and select Posts/All Posts. On the list of Posts that comes up, mouse over a Post that you want to show up in the slider and select “Edit” (not “Quick Edit”). The “Edit” page has a box labeled “Publish.” In this box, under “Visibility,” select “Public” and check the box titled “Stick this post to the front page.” (This is what makes a post “Sticky.” By the way, this option is also available in the “Quick Edit” menu, where you can select the option for “Make this post sticky,” but we also need to set a Featured Image, which requires the “Edit” menu, which is why I’m steering clear of the “Quick Edit” menu.) So far, you’ve told Oxygen that this Post should be one of the Posts featured in the slider. It is my understanding that unless you make the Post “Sticky” it will not show up in the slider. Now, you just need to tell Oxygen what image to use in the slider to showcase this Post. Still in the “Edit” menu, go to the box labeled “Featured Image,” and click on the option “Set a featured image.” Click the button labeled “Select files,” and select the file on your computer that you wish to use as your banner image for this Post. When it uploads, scroll down to the bottom and select “Use as Featured Image.” (None of the pre-set sizes available for you to choose will be 750×380, which is strange, but selecting the “Full Size” option results in the correct image showing in the slider even though “Full Size” purportedly re-sizes the image to 470×238 according to my menu.) Do not click the “Insert into Post” button, since right now you’re not trying to insert the image into the Post; you’re just trying to get it to show up in the slider. On the image window, click “Save all changes,” which will bring you back to the “Edit” screen. Then, in the “Publish” box, click “Update” to save your changes.

    Word for word, step by step, these are the exact measures I took to get my slider working. If that doesn’t work for you, I suggest contacting DevPress, the people who made Oxygen, to see about troubleshooting.

    Hope that works!




    numberstrong , Steve, un énorme merci pour vos explications. Tout parait si simple maintenant !!!!
    Il me manque cependant à comprendre comment insérer les petites images du dessous. (450 pixels).



    J’ai résolu le problème !!! ;))



    Just wanted to thank you for the detailed response. I actually got most of it to work but for some bizarre reason I can only get one post to appear in the slider. If I stick any other post it disappears from the Home Page I created. The frustration is endless. For the life of me, I can’t understand why WordPress does not have better instructions SMH.


    I can’t understand why WordPress does not have better instructions SMH.

    I can’t understand why people don’t use search. The regular Volunteers have responded to so many threads on this topic that we groan when we see it posted yet again as we know that means people did not search and read our previous answers.

    Oxygen Theme Description http://theme.wordpress.com/themes/oxygen Live demo site http://oxygendemo.wordpress.com/

    In Oxygen you can either have a Home page that displays your posts or a static front page ie. a Showcase template. http://en.support.wordpress.com/pages/front-page/#setting-up-a-static-front-page

    Showcase page template
    When you first activate Oxygen, you’ll see your posts in a traditional blog format but if you’d like to showcase your content in an online magazine-like fashion, then you can use the Showcase Page template. …

    Post thumbnails are 470 pixels wide, unless you make the post Sticky to show off in the featured slider, in which case they’re 750 pixels wide. Keep in mind: if you mark a post as Sticky but the featured image is less than 750 pixels wide, then it won’t display in the slider and will still disappear from the river of posts.
    Please be aware that you cannot crop the sticky post thumbnails.

    Sticky post thumbnails are 750 pixels wide in the featured slider
    Regular post thumbnails are 470 pixels wide

    If you don’t see the page attributes module then make sure that you don’t have it hidden in your screen options http://en.support.wordpress.com/screen-options/
    Modules to unhide:
    Post – Likes and Shares, Format*, Categories, Tags, Excerpt, Send Trackbacks, Discussion, Comments**, Slug, Author, Revisions, Writing Helper
    Page – Likes and Shares, Page Attributes, Featured Image, Discussion, Comments**, Page Revisions, Slug, Author, Revisions, Writing Helper



    I think what may be happening is this: the instructions on the page you referred to are easily understandable to someone who already knows the WordPress lingo (e.g., “showcase page,” “sticky”), but for someone who is making their first site, there is a learning curve.

    I hope that my response above will clear up a lot of future problems before they get resurrected in the forums.


    I wasn’t referring only to the theme description. Note the sidebar of this thread and the tags I placed there:

    All support documentation is here > http://en.support.wordpress.com and that link is on the bottom of our Admin pages as well as in many other locations on the site. Typing the keywords into the searchbox provides results form both the support docs and from forum threads.

    P.S. Thanks for helping and best wishes with your blog.



    Numberstrong, your detailed instructions are amazing – I was only able to get the Showcase Page to work beautifully after reading YOUR instructions. So many other threads copy and paste that same exact set of directions, but they are not very clear. Especially to people like me who do not know much about configuring WordPress themes. @thistimethisspace – Obviously, copying and pasting that same set of directions over and over and over and over on all of the related Oxygen Showcase Page problem threads isnt working. TimeThief does that too. There are always follow up questions by other users after that copied and pasted set of directions is posted – “It didn’t work- help!” – and those people are just ignored.

    Again, thank you VERY VERY much to numberstrong for posting an original set of directions that is actually helpful and thorough!!!



    I agree with seafoamlife about numberstrong! I read soo many other posts on this and I still couldn’t get it. I was starting to feel really stupid. Thanks numberstrong for breaking it down.


    Numberstrong, cannot thank you enough mate. Cheers.



    I have deleted my site, my hours of work – in the hope that I could restart Oxygen, to click the “Showcase” option and get the slider working. Nothing. There must be a remnant from the old site because the option never came up. I was immediately led to a dashboard. HELP!

    Here’s what I did on the “new” site (foolishly thinking I could start a new blog): created a Home page, created a Latest News! page, clicked settings > reading > static page > front page > posts page, wrote a post, set the picture to 750px wide, set the picture as featured, published. Nothing.

    There’s a remnant, I swear! HELP ME BEFORE I GO MAD, MAD I TELL YOU!



    Oh yeah, and I clicked the sticky button.



    And I unclicked the sticky button.

The topic ‘Oxygen: The god awful Slider. NEED HELP.’ is closed to new replies.