oxygen theme : way to not show sticky posts in blog page?

  • Author
  • #938478


    I have a question, hope the following makes sense to you, my apologies if my english is not so good.

    I have Oxygen theme activated. I created the static page to serve as Showcase Page. All ok with this, featured posts slider, etc all is ok.

    Now, I’m thinking that since sticky posts are featured in the slider and in the showcase page, it is a redundancy (the way I think of it) for those posts to be shown again on top of all other posts, as sticky, in the blog page (I mean the parent page that hosts all posts in the classic chronological order).

    Is there a way to keep the sticky posts featured in the Showcase page but NOT show them as sticky (i.e. on top of all the rest) in the blog page ?

    The blog I need help with is roadspirit.wordpress.com.



    This doesn’t answer your question, but how did you set up the slider and showcase page? It’s not working for me.



    First of all you will have to mark the posts that you want to appear on the slider as “sticky”. You do that when you create a post or when you edit one, the “sticky” option is on the panel where you choose visibility: “public”, choose “show on 1st page”.
    Then, you will have to designate a “featured image” for the post and it has to be at least 750 pixels wide. If it is not, the post will not appear on the slider.
    Next, you have to create two pages. The one, will be set as a Showcase (from its page options). Rename it as you wish, for example on my blog it is the “Home” page. Also, you will have to set your blog to appear with a static page and choose the showcased page as the static one (on the dashboard->settings menu -> reading options).
    Finally, the 2nd page you must create is the page that will hold all your posts, in the classic order (from newer to older). Create the 2nd page, name it (for example “blog”) then designate it as the “posts page” on the dashboard->settings menu -> reading options


    Thank you Roadspirit for asking this question. I feel that it is redundant as well. I hope we get an answer soon.


    Hi Roadspirit,
    I think I may have an answer for you.
    I just tried setting up my Showcase Page with a Sticky Post (and Featured Image) – in Oxygen theme. I’m currently testing this theme so by the time you look at my page, it may not be in the Oxygen theme.
    Above you say that you created two pages. I only created one (1) page and called it my Home Page. I set the Home Page as the Showcase page, which seems to have worked.

    I clicked on one of the posts and the page did NOT have the sticky/featured post at the top.

    Is this what you’re having trouble with?



    a) That’s the way sticky posts are supposed to work, and it’s not redundant: it would be redundant if they showed up twice on the same page.
    b) The Showcase template is a complex alternative to a conventional main page: you don’t have to use both.

The topic ‘oxygen theme : way to not show sticky posts in blog page?’ is closed to new replies.