Page Disappears?

  • Author
    Posts
  • #824836

    timethief
    Member

    FWIW I flagged this thread for Staff attention previously.

    #824837

    justpi
    Member

    Yes, maybe a bug.

    The Theme Locations module is found in Appearance > Menus. Wrong menu in that pulldown is the most likely cause when a tab for a new page doesn’t show up, but naturally that can’t be the reason if you see the tab then you don’t.

    What’s the title and the URL of the new page? Can you see it in Pages > All Pages?

    #824838

    timethief
    Member

    @justpi
    “Yes, maybe a bug.”
    That’s what I’m thinking too.

    #824839

    itsbarc
    Member

    Title: Feedback
    URL: http://weekendatbarcies.wordpress.com/feedback/

    It auto made the URL when I named it. And yes I can see the page under all pages. And on the dashboard it says I have 3 pages. The link works to my page and everything. Its just not showing up by my other pages.

    #824840

    justpi
    Member

    @itsbarc: As I just wrote, that’s probably not the reason, but anyway the selection in the Theme Locations pulldown can change by itself or if you switch to a different theme.

    #824841

    itsbarc
    Member

    Ive never messed with the menus before.
    So I went to appearance and menus. Created a menu and checked the boxed by my pages and clicked add to menu.

    And under Theme Locations and then Primary Menu I put the blank?

    #824842

    itsbarc
    Member

    Also I just updated a different page and clicked update, checked my page and the feedback page was there, but then again it went away. Even when I update other pages it comes back for a second.

    #824843

    justpi
    Member

    @TT: If I decide to buy us some drinks each day WP doesn’t tinker with anything, I’m afraid we’ll die of thirst.

    #824845

    justpi
    Member

    @itsbarc: When you select the blank option, the theme should display its regular top menu (the one that seems to be malfunctioning at the moment). As pimamedia found out, you can sidestep the issue by creating a custom menu, adding your pages to it, and selecting that menu from the Theme Locations pulldown. More detailed instructions here:
    http://wpbtips.wordpress.com/2011/12/19/custom-menus/

    #824847

    Yes, I used Pimamedia’s work around and my pages showed up.

    that is:
    Dashboard>Appearance>Menues
    -Create a custom menu (name it anything)
    -add the tabs you want from your Pages
    -select Theme Locations
    -Go to the bottom of the screen, and from the Theme Locations box, select your new custom menu from the pull down tab.

    worked for me. Thanks.

    #824848

    forgot to say…..(and I know it’s already been said)… but you can find the “theme locations” tick box in the “Screen Options” pull down at the top of the screen

    #824854

    timethief
    Member

    @itsbarc
    Have you resolved your issue? I see these Pages >
    Home
    About
    Feedback
    Pong University

    #824855

    itsbarc
    Member

    I did the work around that they have been talking about. This works fine and honestly if I would have known about this I wouldnt of complained.

    But if youre wondering it still is not working the proper way.

    Thanks for all the help!

    #824856

    timethief
    Member

    Thanks for the confirmation that it’s still not working the right way and a workaround has to be used. I’m leaving the tag on for Staff so they are aware of this.

    #824868

    bona88milan
    Member

    This meted works with me:

    Dashboard>Appearance>Menues
    -Create a custom menu (name it anything)
    -add the tabs you want from your Pages
    -select Theme Locations
    -Go to the bottom of the screen, and from the Theme Locations box, select your new custom menu from the pull down tab.

    But i hope that the Staff can resolve the problem!

    #824871

    atownend
    Member

    New pages not listed as static pages under readings settings menu — may be similar issue to those referred to in this thread?

    I am trying to set up some new pages on my blog. I am using the twenty eleven theme. When I have created the new pages and I go to the reading settings page, those new pages do not show up under the drop down menu for static pages, in fact the pages that do appear there are now out of date. Please could you advise what is happening and how i can correct this?

    #824875

    atownend
    Member

    in response to my own post above….Solved …simply pressed save on the reading settings page (before making any changes to the settings) and that made the new pages appear under the drop down menu.

    #824878

    I’m having the same problem: I just created a new page (called “Completed”) and a sub-page of that page (called “The Spirit of the Liturgy: Posts”). They are showing up on my dashboard as “published”. But I can’t see any tabs for them from the home page. Where are they?
    http://tiffanyanntheology.wordpress.com/

    Thanks for any help.

    #824884

    bona88milan
    Member

    I think its a wordpress problem.

    #824887

    I am another person having the exact same problem, with a blog I just signed up for today. I have created two pages on the top navbar, they are showing up as published in the editing console, but not on the blog itself. If I fiddle with the settings, they display until I refresh the page, after which they disappear again, just as others have reported.

    I haven’t got any custom pages set up. I created one simply so I could access the dropdown that people keep mentioning, but that made no difference, no matter what I checked/highlighted/applied.

    I must say, I’m finding this all a bit stressful!

The topic ‘Page Disappears?’ is closed to new replies.