‘Page Links To’ Option Gone in Gutenberg

  • Author
    Posts
  • #3194075

    rallyny
    Member

    In WordPress classic, I have the VERY SIMPLE OPTION to click ‘custom link’ to have the page title or image link out somewhere beyond my page. In Gutenberg, I can find no way to do this. I’m stuck constantly toggling back and forth between Gutenberg and Classic to get every post completed. Very frustrating. Maybe it’s one of the endless blocks I’m supposed to add, but nothing pops out at me as obvious or easy to identify and use for this purpose. HELP PLEASE. Also, I tried to download the Classic Plugin but it doesn’t work, so I need to figure out how to do this simple task in Gutenberg,

    #3195570

    reginabally
    Member

    Hi there,

    To add a link to any text to an external URL on Gutenberg, see the steps in the image below.

    For images, after you’ve added the image block, you can add the custom link at the Link Settings. Choose Custom URL at the Link To drop-down list and enter the link at the Link URL textbox.

    #3196310

    rallyny
    Member

    Thanks but this actually isn’t where my problem is. It’ the Title that I want to be able to link out to an external page. I can see no way to do that.

    #3196318

    reginabally
    Member

    The Title you mentioned is it the post/page title or the heading in the post/page? Is it something like this screenshot?

    By the way, could you share your site address? If you’re using the self-hosted WordPress version, there’s a better place to seek help for Gutenberg as this is the support forum for sites hosted on WordPress.com.

    See the differences between WordPress.com and self-hosted WordPress here:
    https://en.support.wordpress.com/com-vs-org/

    #3196326

    rallyny
    Member

    Thanks for still trying to help. I’m tearing my hair out at this point! It’s the title of the post, I can’t see here where to attach a screenshot but it’s like this:

    Costa Rica Beaches, Volcano & Rainforest Adventure

    This Central American gem should be on every Bucket List…..blahblahblah

    The “Costa Rica” title needs to be linked out to the deal page on another site. In Classic WordPress this was a “Page Links To” option right below the body copy. Now in Gutenberg that is gone and I can find no way to do it other than to toggle back to Classic, which I have to do after every save. It’s insane that there is no way to link out a title! I don’t want to link some words in the body. The whole title needs to link out. The site is https://traveldealsandnews.com/ and I have no idea where it is hosted. I am doing some freelance work for the site owner and I guess about a month ago when I logged into WP I encountered this Gutenberg with no explanation or tutorials, and he doesn’t know anything about this new system. I think maybe he didn’t even know of the change until I told him. I’m so frustrated!

    #3196331

    reginabally
    Member

    I can totally understand the frustration especially when we’re trying to get things done quickly but we don’t have an idea on how it works on the new user interface.

    I think the theme of the site you’re working on is not the original Twenty Seventeen theme. It’s using a child theme of Twenty Seventeen, which means that the theme is modified and customized for the site. Sometimes these modifications could cause incompatibility with Gutenberg. Not all themes are Gutenberg-friendly now.

    If you’re uncomfortable to use Gutenberg for the editing now, you can edit the post using the Classic Editor for now.

    If you need more help on Gutenberg, I would suggest to get help from the Gutenberg plugin support forum. Who knows maybe you discovered a new bug and end up contributed to the WordPress community? :)

    I’m sorry that I couldn’t help much on this. I do hope you’re able to get things done with the Classic Editor for now.

    P/S:
    – To edit post/page using Classic Editor, hover over the post/page that you wish to edit on the All Pages/All Posts screen and click Classic Editor link.
    – To start a new post/page using Classic Editor, at the All Pages/All Posts screen, click the down arrow at the Add New button and choose Classic Editor.

    Best of luck!

    #3196334

    rallyny
    Member

    OOOOOHHH!!!! Thank you so much for pointing out the “Add New” dropdown at the top, from where I can select Classic to start! I had never noticed that and thought I had no choice but to start via Gutenberg by clicking “Add New” in the left-hand frame. Then being forced to toggle back and forth between G and Classic. That alone is such a huge help thank you. Hopefully they will leave that there for us permanently!

    And I will go to the G plugin support forum as you suggest to see if I can find out anything else or contribute as you say with new info =)

    Thank you again for doing all you could to help. Much appreciated.

    #3196335

    reginabally
    Member

    You’re welcome. Glad that I’m able to help. :)

You must be logged in to reply to this topic.