Need help? Check out our Support site, then

page not loading

  1. jasonkalinowski

    I am new and just setup my username and password. My browser got hung up when going through the setup and stalled at choosing your theme. I can log in now but I can't create a post. The page keeps telling me its loading but it never does.

    Help please?
    Blog url:

  2. Hi Jaso0n,
    I'm sorry this is happening to you. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    If you are running a current browser version, please do these four things:

    1. Let us know which browser (and version of it) you’re using.

    2. Try clearing your browser’s cache:

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

  3. jasonkalinowski

    Thanks for getting back to me!

    So I am running Safari 6.0.1, I have cleared the cookies and cache. Upon further navigation of the page I am able to access some of the features through my name drop down on the top right of the page. From here I can navigate, but when I first log in to my page I am not able to access any of the buttons or options without going into my name drop down. Is this the way the page is supposed to operate?


  4. I recommend that you log-in directly to your own blog by using this link

    There's an issue with creating posts on the front page of that will not be fixed until the next upgrade. Do not create posts here >!/post/

    Instead I recommend that you ONLY create posts here > Dashboard > Posts > All Posts > Add New

  5. jasonkalinowski

    Works like a charm! Thanks.

  6. Hooray! Happy blogging. :)

Topic Closed

This topic has been closed to new replies.

About this Topic