Page not showing up

  • Author
    Posts
  • #1414601

    majomajo
    Member

    My dashboard shows that I have five pages published, but one of them (“mania-depression scale”) is not showing up. Help please….

    The blog I need help with is bipolarintegrity.com.

    #1414689

    majomajo
    Member

    I meant to say six pages supposed to be visible.

    #1414693

    timethief
    Member

    Troubleshooting – My Pages aren’t appearing in my custom menu
    They must be public pages – not private and not draft.

    Public – The page will be visible to everyone.
    Protected – The page is protected with a password you set. Only people who have the password can view a protected page.
    Private – Pages are only visible to blog Editors and Administrators. Private pages are not visible in Reader, feeds, or in any search. A page can be private without being password protected.

    edit pages screen http://en.support.wordpress.com/pages/edit-pages-screen/
    http://en.support.wordpress.com/menus/#adding-pages

    Here’s a link to a custom menu walkthrough > http://onecoolsitebloggingtips.com/2011/08/11/wordpress-com-custom-menu-walk-through/

    There are many common errors, misunderstanding and misconceptions when creating custom menus and you can read about them here > http://wpbtips.wordpress.com/2011/12/19/custom-menus/

    #1414812

    majomajo
    Member

    That page is clicked as published and public, but still doesn’t show up.

    #1414813

    justpi
    Member

    You’ve published it as a child page to “My journey”. If you want its label to show in the top menu along with the other ones, edit the page and select “no parent” from the Parent pulldown.

    #1414814

    enricator
    Member

    Totally agree with justpi

    #1414815

    majomajo
    Member

    Thanks, but that does not seem to be the issue. I did try that – after earlier problems with it not showing up – just to see if it became more visible then. I thought maybe there was some limit for how many pages you can show at the top. I now have edited it to have no parent and it still does not show up as a page at the top. I appreciate your help with this.

    #1414816

    raincoaster
    Member

    Are you using a Custom Menu perchance? If so, you will have to add it in manually.

    #1414817

    majomajo
    Member

    I don’t think so, because I don’t even know what a custom menu is.

    #1414818

    justpi
    Member

    @majomajo: You’re welcome.
    No, there’s no limit to how many labels you can show at the top (although the labels on MistyLook don’t look good when there’s more than one line of them). The regular menu of the theme automatically displays all your published parent pages. If the page didn’t show now that you turned it to a parent page, then you’re using a custom menu instead of the regular menu (as raincoaster said). Since your menu includes only static pages, in alphabetical order, you don’t need a custom menu at all: go to Appearance > Menus, click Manage Locations, set the “primary navigation” pulldown to “Select a menu” (so that no menu is selected), click Save Changes.

    #1414819

    majomajo
    Member

    Well, the primary navigation pulldown was already on “Select a menu”, so I can’t see anything to change.

    Since you say that MistyLook doesn’t look good with more than one line of Page labels, maybe it would fix the problem if I switched to a different template? I’m not wedded to MistyLook, it’s just familiar to me. If there’s another one that would be equally user friendly to me – maybe keep my widgets – but perhaps handle these Page labels better, I’d be glad to switch.

    #1414820

    justpi
    Member

    Sorry I didn’t notice this before: when you turned the page to a parent page, it did show at the top, but it’s hidden behind the search box… Go to Appearance > Theme Options, check the option “Yes, I’d like to hide the header search form”, click Save Options.

    If you agree that the upper line of the top menu doesn’t look very nice, you can switch to any other theme that has a sidebar. I can’t suggest any theme in particular because there’s too many of them. You can preview all of them in Appearance > Themes.

    #1414821

    majomajo
    Member

    Great – that totally did the trick.

    Sometime when I have some time on my hands, I’ll play around with some other Themes. I’m pretty attached to the photo I have on top – the play of light and dark (and I took it!) – so I would have to find another theme that let me use it.

    I appreciate your patience and resourcefulness with this.

    #1414822

    raincoaster
    Member

    You can use the Theme Filter on the Themes page to search for themes with a Custom Header.

    #1414823

    majomajo
    Member

    Cool, thanks.

The topic ‘Page not showing up’ is closed to new replies.