Page Order- Followed FAQs and still not working

  • Author
  • #258820

    Hi again all!

    I’m putting together a blog at:

    I’m wanting the navigation bar to display pages in the following order: Home, Products, Nutritional Information, About, Contact.

    To do this, I have changed the page orders on each of the pages: Home (static front page), Products (0), Nutritional Information (1), About (2), Contact (3)- however, this has not changed the order on the site, where Products sits last.

    I have searched the FAQs and Forums and there are no further answers than what I have done.

    Any ideas on how to fix this would be greatly appreciated!




    Try this:
    Home 0
    Products 1
    Nutritional Info 2
    About 3
    Contact 4


    Hmm.. My concern then is that my home page will show up twice in the navigation bar, as it has previously (see forum discussion at

    I tried to change themes to resolve the last issue, but this one suits in terms of style. Is there any way to resolve this and have a Navigation Bar with all of the page names showing once, and in order?




    You don’t need to take the 2nd home page into consideration because it’s been “hidden” by making it a Child Page. Did you try the order I suggested? If it doesn’t work, then try making Home 1, Products 2, etc.


    I don’t have a second home page… there’s just the one under Manage>Pages, and it’s the child of ‘Blank’, which is the child of ‘About’. I have added the page widget so you can see where everything is- my ideal solution would be to have the order you’ve specified above!



    Yes, I remember you mentioned that in your other thread.

    Well give it a try, then and come back and post if it worked?


    Sorry- I’m not clear.

    Are you suggesting I should remove the Home Page as the child of About>Blank and make it a main page, then change this order?


    Hi Jennifer or anyone else who can help,

    I did as you suggested- took Home out from About>Blank, then changed the order of the pages. As you can see at, the navigation bar now has two ‘Home’ links but is still not in the correct order. As you should also be able to see in the Page widget in the side bar, the order of pages is how it should be!

    Any other ideas?



    Sandra, sorry if I wasn’t clear. I wasn’t suggesting that you remove the Child Home Page, just that you reorder your Parent Pages as I suggested above. If it still didn’t work, then I’m out of ideas.



    – The ordering starts with 1, not 0.

    – For the orderinng to work, you must go to the Page widget, click Edit, and select the “Sort by Page order” option.

    – For the double Home page see here:



    Ah dear panaghiotisadam, she is trying to change the order of the pages as they appear in the navbar, not the widget. The page widget has been temporarily enabled so we can see the location of the 2nd home page. See the previous thread sandraandsharon has linked to above.


    Oh you’re right! I keep forgetting that the command in the widget is …for the widget!

    But I think I’ll behave this time – went to the lab and checked things. The “About” page is a default page of the theme, ans its tab is set to be next to the “Home” tab. If sandraandsharon deletes the page and writes a new one, she’ll be able to put it in the order she likes.



    I actually have changed the order of my Pages in my navbar using the numbers. The NavBar normally arranges things alphabetically, which may explain why the About page is right next to the Home page, as it is next “in line”. :)

The topic ‘Page Order- Followed FAQs and still not working’ is closed to new replies.