Page ordering not working

  • Author
    Posts
  • #37938

    ukgames
    Member

    I am trying to order my pages so that the navigation bar of my blog displays them in the order I want them to be arranged. I have used 1 for the page that I want to be first in the navigation bar and have used 2, 3, 4 etc to continue along the navigation bar. It just doesn’t seem to be working for me.

    #38273

    drmike
    Member

    The theme may be overriding the display but without seeing it, (that’s a hint for a link) there’s no way we can tell.

    I’m reading a very nice book. It’s here in front of the screen. It’s got a blue cover. Can you tell me the title? :)

    #38507

    sasc
    Member

    huh? i’m having the same problem. any ideas?

    #38508

    judyb12
    Member

    You can always put a number in the title, although that’s not very pretty. Unfortunately, a lot of themes override the page numbering and default to alphabetical.

    #38518

    postclever
    Member

    I’m seVEREly disappointed. WordPress seemed like such an approachable and maleable platform at first but as I roll up my sleeves even a little to try to make EXTREMELY simple changes like, oh, I dunno, TAB ORDER!?, I realize it’s just another piece of open source s**t cobbled together by basement-dwelling, code-breathing expert users. Sigh… Back to Dreamweaver I go.

    #38519

    disembedded
    Member

    Yes, I have to use numbering for pages also (Garland Theme). I use Roman Numerals, which doesn’t look too bad:

    http://disembedded.wordpress.com/

    #38520

    raincoaster
    Member

    We’ll miss you more than you know.

    #38521

    drmike
    Member

    Postcleaver, maybe asking instead of complaining would have gotten you an answer.

    Espcecially considering it appears that you’re in the wrong place and at the wrong site.

    *chuckle* Running Dreamweaver and can’t read a post labeled “Please read me first before posting.” It’s pretty sad actually…

    #38522

    maxzook
    Member

    I’m having the same problem as the previous posters; let me try to quantify it.

    Go to http://maxzook.wordpress.com, which is set up with the Regulus theme. You’ll see my page tabs in the following order:

    * [blank]
    * Eighty-Eight Frequencies
    * Equity
    * Tabula Rasa
    * Babes In Armor
    * Voices in Conflict: Free speech in an American high school

    The blank page header is an intentional “Easter Egg” and I’m not changing anything in it so I assume it isn’t affecting the problem.

    Until this morning the Page Order numbers were set as follows:

    * [blank] — 1
    * Eighty-Eight Frequencies — 2
    * Equity — 3
    * Tabula Rasa — 4
    * Babes In Armor — 5
    * Voices in Conflict: Free speech in an American high school — 99

    To fix the layout problem with the overhang, I went in to http://maxzook.wordpress.com/wp-admin/edit-pages.php and changed the Page Order numbers to:

    * [blank] — 1 (unchanged)
    * Voices in Conflict: Free speech in an American high school — 5
    * Eighty-Eight Frequencies — 10
    * Equity — 15
    * Tabula Rasa — 20
    * Babes In Armor — 25

    Now, the Manage Pages page is showing the pages in the order I want to see them tabbed onscreen, and the individual pages have the Page Order rankings that I assigned above (so it’s not like the widgets problem where newly-entered data isn’t being saved). But the page tabs are still appearing onscreen in the old order.

    That’s the problem as it plays from here. Any suggestions?

    #38523

    brucejeffers
    Member

    I believe the ordering of your pages is a cache issue, which is related to the current widget/new page problem currently being worked on by Support. After they have fixed this problem, your ordering should work just as normal, using numbers 1, 2, 3, etc.

    #38524

    drmike
    Member

    Max, there’s now a sticky at teh head of the forums about an issue with the cache affecting how Pages are displayed. Since we have folks having an issue with new Pages being displayed, this may be related.

    I will mention though that it appears that regulus is suppose to display the Page order that you set:

    wp_list_pages('sort_column=menu_order&depth=1&title_li=')

    Says menu_order which would mean what you’re setting it to.

    Hopefully they’ll get this fixed asap. :)

    As an aside, you may want to edit that blank title Page and give it a title when all this is fixed.

    Hope this helps,
    -drmike

The topic ‘Page ordering not working’ is closed to new replies.