Page passwords do not work in Internet Explorer

  • Author
  • #1259160


    I run a small website for a hobby club. This is built on a standard WordPress theme of “Misty Lake”. Most of the site is open to the public, but there are a couple of pages which contain information only of relevance to members, which I have password protected.
    The website is

    My problem is that the website works fine to anyone using Chrome, Safari, or Firefox. If anyone tries to access the site using Internet Explorer (all versions including IE10), the password function does not work. When you try to enter a password, there is no indication on the screen that the password has been recorded, and when you hit “enter” the page just recycles and asks you for the password again.
    Earlier versions of IE also have a distorted layout on the screen as well as the password being non – functional.

    Is this a deficiency of the code in which WordPress is written, or is there some simple instructions I can provide to club members who operate Internet Explorer (bearing in mind that most of them have limited computer skills) that will enable them to access the site.?

    Dave M

    The blog I need help with is



    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.


    Hi Dave,

    Could you please confirm the blog for which you are having issues? I was unable to access



    I’m in Canada on a PC and using Firefox 20 and I can access


    Thanks @timethief, must have been network issues on my end earlier.

    It looks like is not mapped to a blog. I see that the site does contain within an iFrame. @kapitiflyers, could you confirm that you are still having issues with password posts when accessing directly and not from the iFrame?



    Hi guys – thanks for your support
    The website is hosted by WordPress, but we use a separate URL to make it easier for search engines to find us.

    The WordPress site is www.

    and the URL is

    There is no difference between using the WordPress address or the URL. Both give problems to IE users

    As a interim solution I have removed the password protection from most of the pages. The only page which has password protection is “At the Flying Field” in the “members pages” section . IE users cannot access this page, although users with other browsers have no difficulty.

    Our problem seems to be limited to Internet Explorer users only – would like to know if (and how to) tweak the WordPress site, or whether IE users need to somehow reconfigure their systems.

    As another observation – the page layout changes under IE. Instead of the menu bar being across the top of the page, IE users find it is vertical in the centre of the page. Annoying but not a major issue.

    Thanks in advance!


    Hi Dave,

    Can you double-check that your visitors are still having issues with the password field when accessing your post directly (not within the frame)? I was able to recreate the problem you are describing in IE when going to your site within the frame, but when viewing it directly I had no issues.

    Internet Explorer (and some other browsers) have issues setting cookies within framed documents, which is why we do not recommend framing your blog. If you’d like to use your domain for your blog, I would recommend reading Map an Existing Domain.



    Have done a limited check. On IE10 visitors can access the password protected pages when access WordPress directly, but cannot access from the URL. I think this is what you refer to as a “frame”.
    On IE8 cannot access through either site.



    Just to clarify – Our website is hosted by WordPress, but is accessed by visitors using a registered domain name of
    I am not sure if the relationship between the domain URL and the WordPress address is a “frame”. (beyond my technical understanding)



    I have been advised the following from a club member who has more computer experience than me. “It is a cookie restriction level problem. I suspect that info is written to a cookie before the prog goes to the validation site but that cookie isn’t being accepted.

    The fix is to go to menu item Tools/Internet Options/Privacy and move the slider down one notch to ‘Low’. IE’s default on cookies is a bit high it seems.”
    This fix seems to work. I am hesitant to advise people to reduce their security settings, when it is only the WordPress site which is affected. Is there some reason why the WordPress cookie is not being accepted by IE ?. Can this be addressed?


    The registrar for your domain,, is DiscountDomains is providing a service that frames your address so that is shown in the address bar.

    Security settings in several browsers prevent sites from dropping cookies when the site is framed. This is not a restriction unique to My recommendation would be to update your settings with DiscountDomains such that your domain redirects to your address, or, if you want to map your domain to your blog so that your domain continues to appear in the url, purchase the Domain Mapping Upgrade.



    I have received the following response from Discount Domains. Can someone translate this into layman’s language and give me a simple set of instructions of what I have to do.

    Framing a website within another URL, is not always suitable, and clearly Internet Explorer objects to getting secure content through the frame from the WordPress blog.
    Rather than frame the website, you can simply update WordPress blog to accept requests for your domain,

    This will require that the DNS A records for this domain are updated to use the IP address of the Word press web server hosting your site.
    Please discuss with the Word press support team regarding the accepted domains for your blog, and confirm the updates required to the DNS records for your domain.
    This will require us to update the domain, however we need to know first where we are to update it to, which Word press can clarify

    thanks. Dave M

The topic ‘Page passwords do not work in Internet Explorer’ is closed to new replies.