Pages on my blog

  • Author
    Posts
  • #3436148

    Hi, I deleted my Home page which was empty and I want it to just say Home and take them to the display of all of my blog posts. I only have one other page About so I want them to be able to click back to the Home page. How can I do this?

    #3436262

    supernovia
    Staff

    Hi @greengranny92, could you send a link to the site you’re having trouble with? Generally speaking you can get this effect if you go to Customize > Homepage Settings and choose to display the latest posts.

    #3436563

    https://greenertogether.wordpress.com/

    This is the site. I tried to do what you sad but I don’t see it.

    #3436569

    When people first visit your site they land on your blog posts page. You need to delete the “home” page which links to a site you have deleted and add the blog page to your menu (renaming it to “home” if you wish).

    #3436573

    I deleted the Home page. My only page now is About, but for some reason the Home is still showing up.

    If I did want to add a new Home page, how would I even copy all of the content that is on the blog page?

    #3436788

    You don’t need to copy the content. Instead, the setting needs changed so that the posts display as the front page. Take a look at these instructions and write back to me here if you need further help.

    https://en.support.wordpress.com/pages/front-page/

    #3437033

    Thanks, I followed the article you sent and it is already set to displaying my latest posts. The problem is that the button that says Home on my set is leading to this https://treelovinghippy.wordpress.com/ (my old site). I’ve deleted the page itself and it’s still showing up!

    #3437114

    fstat
    Staff

    To fix that you need to edit your menu (My Site > Design > Customize > Menus > Menu). Remove the old Home item and add a new one. The new one will have the correct link to your site.

You must be logged in to reply to this topic.