Paid for domain name, have receipt, but still no domain???

  • Author
    Posts
  • #2270880

    oliviamair
    Member

    Hi,

    I’m hoping someone can point me in the right direction as trying to find an actual contact on here is proving extremely difficult.

    I’ve had my domain http://www.whereswiwi.com for a few years and had it on auto renewal.

    This year I received the receipt for my renewal as normal (#10400994). Unfortunately at a similar time there was a fraud issue with my credit card and I was issued a new number. Since I had received the receipt I didn’t think there was an issue – I received NO further contact from WordPress.

    A little while later someone commented to me they couldn’t see my website. After a little investigation I noticed an alert buried in “Store” (with no notification anywhere at all) to say there had been a chargeback and I needed to submit another card.

    I submitted the new card number, received a receipt (#12033121) that included an additional chargeback charge AND NOW I STILL HAVE NO PERSONAL DOMAIN.

    Could a WordPress staff member please urgently contact me regarding this as I have tried to do the right thing despite a complete lack of communication from you surrounding this issue but I’m still in the wilderness with my website.

    Thanks to anyone who can help me out here.

    The blog I need help with is whereswiwi.wordpress.com.

    #2270965

    auxclass
    Member

    flagged for the staff to help

    #2270968

    oliviamair
    Member

    Thank you @auxclass

    #2270969

    auxclass
    Member

    You be welcome

    #2271132

    Hi there!

    Thanks for reaching out! I just checked in with our store team about this. I’ve refunded the Chargeback charge, since we were never penalized for the chargeback. And I’ve reinstated your domain.

    You may need to update your primary domain here:

    http://en.support.wordpress.com/domains/#setting-the-primary-domain

    Let me know if you have any more questions!

    #2271149

    oliviamair
    Member

    Thanks you so much for getting back to me!

    I can see that under My Upgrades it confirms my domain is active and will renew Feb16, however under My Domains, it still only lists the .wordpress.com version.

    Do i need to go through the Map a Domain you already own button, but that seems to be for external websites???

    Thanks Olivia

    #2271151

    Sorry about that! The domain didn’t restore quite right. I’ve just fixed this. You should see it listed here now:

    https://wordpress.com/my-domains

    #2271158

    oliviamair
    Member

    Thank you, I’m back on the grid!

    Thanks again for getting onto this so quickly, much appreciated.

    Cheers Olivia

    #2271165

    Happy to help Olivia! Sorry about the mixup. :)

    Let me know if I can help with anything else!

The topic ‘Paid for domain name, have receipt, but still no domain???’ is closed to new replies.