Paragraph breaks disappear when I edit a post

  • Author
    Posts
  • #201621

    jd1220
    Member

    For some reason, every time I re-open a draft to edit something, it publishes the draft as one big paragraph and I have to go back through the whole thing and hit enter however many times.

    What am I doing wrong?

    #201831

    ellaella
    Member

    In between editing the draft and “it publishes” did you use the preview feature to see how it would display? Was there a difference? What did you do?

    #201832

    ellaella
    Member

    Oh, and probably more pertinent, which browser are you using? Safari doesn’t play well with TinyMCE, the editor in your visual tab.

    #201838

    jd1220
    Member

    I am using Safari…the preview feature always looks good until I publish.

    #201843

    ellaella
    Member

    Try using Firefox. TinyMCE doesn’t fully support Safari.

    I would tell you how it looks in IE7 but you didn’t give us a link to your blog or link it to your user name. It’s not too late! :)

    #201850

    I went through this last week and nearly threw my computer out the window. Every time I tried to fix it, it got worse. Don’t use Safari. Use Firefox for now. I’ve heard they are going to support Safari with the next update though.

    #201878

    I’m using firefox and I have the same problem. I’m ready to stop using wordpress.

    I punch in
    , <br/>, in code.. click save and continue editing, it ignores the code, switches to visual and that code is no longer there. It continues to chunk my writing into big paragraphs

    #201882

    I too am using Firefox, on a PC, and I am having the same problem. I have tried the same tricks, like using <br/>, with no luck.

    It appears that this is happening only after I use a table. It doesn’t happen on my simplest pages. This makes me think that some <span> or <div> hidden in the code is not being matched. Here is an example of a page where it is a problem.

    http://czechgreenways.wordpress.com/linz

    Howard

    #201892

    yflcsandi
    Member

    I have the same problem too. I use <p /> codes. I enter spaces in Visual. it doesn’t work. I am using Safari. Gonna try Firefox but am not willing to give up my default browser for WordPress.

    #201916

    Not to be redundant, but I have the same problem. I’m using Safari, and I don’t really mess with the coding. I just type in the visual. When’s this update going to happen?

    #201917

    You’re guess is as good as anyone’s. For right now, I would suggest downloading and using Firefox or Camino which you can uninstall after the update and everything is working with Safari 3.

    #201918

    But this is not just a Safari problem, and it is not just a Mac problem. It is a problem that people are reporting on several different browsers and platforms.

    #201919

    rip94550
    Member

    i use safari. this actually seemed to be ok until very recently. two carriage returns was giving me a blank line between paragraphs, then it stopped. sometimes in the past week i would still get paragraphs, just without an extra line. sometimes i would get one monstrous paragraph.

    anyway, i got around it by inserting a tab between the two carriage returns. (i edit my posts in textwrangler, and i can see \r and \t.)

    right now i’m more concerned that some of my february posts no longer parse.

    vale,
    rip

    #202065

    I have searched on this topic, and it appears to have been a “bug” for at least six months. I realize that this is a free installation, and there is certainly no way my $15 to use custom style sheets pays for the engineering and maintenance of this site. But it doesn’t appear to me that “management” recognizes that this is a problem that needs to be fixed.

    I would be very grateful if the folks at wordpress.com could give us some indication of whether they plan to fix this problem. It seems to have been an open issue for a long, long time, and it apparently makes the software almost unusable for many people, as it does for me.

    #202137

    I don’t know who did what, but the problem seems to have been resolved, at least for me.

    #202139

    Safari 3.x works well with the new wordpress, but the new editor is not compatible browsers older than Safari 3 (2.x.x, 1.x.x).

    #202140

    sondan
    Member

    I too have this problem for about three months using Firefox and windows XP pro. I have also seen other threads about it but no solution. It looks ugly, but I have taken to adding an asterick on a line by itself to get some spacing beween paragraphs since no one seems to have a solution to this ongoing issue.

    Thanks

    #202141

    I’ve been having the same problem. Paragraph breaks work in about half my posts, and I’m getting a bit frustrated. I switched to WP because it is suppose to be the best, but I have been experiencing nothing but bugs over the past several weeks.

    This is getting ridiculous.

    #202439

    voolavex
    Member

    Me too – no matter what I do it decides on its own which spaces to make and which to smush. There has to be a very simple fix for someone like me who has no clue what Firefox or Safari and justs wants to write and post. And why can’t we change fonts and font sizes. Or am I really clueless.

    #202440

    One thing to make sure of is that when you are adding text in your posts, that the format pulldown at the left end of the extended tool bar in your editor says “paragraph.”

    I’ve had the new editor once in a while stop putting in the paragraph breaks if I happen to not exit an ordered or unordered list, or a blockquote properly. The unordered and ordered lists, and the blockquotes now have to be toggled on and off with the buttons in the toolbars. In other words, click the button put in your list or blockquote, then when you have all the text in, hit return one more time and then click the button in the toolbar to exit the function. This will return you to normal paragraph formatting.

    I don’t know that that is the case with either notesunderground or voolavex, but the above cases are the only times I’ve been able to loose the paragraph spacing and I’ve tested it will IE7 and FF on XP, and FF and Safari on Mac.

    The other thing to note as I said in a post above, is that the new editor is not compatible with Safari before version 3. Voolavex, check what version you are using by going to about in the Safari window.

The topic ‘Paragraph breaks disappear when I edit a post’ is closed to new replies.