Paragraph spacing?

  • Author
    Posts
  • #954556

    davekellogg
    Member

    I’m writing a new blog post for the first time in nearly 10 months. My last post appears to be formatted correctly, with a single space between paragraphs. However, the new post I’m working on, when I preview it, is putting paragraphs right up against each other, with no spacing at all between them. In the editor, there is a space there.

    The correct spacing is there if I compose the post in Word and paste into the editor but I’d rather do all the writing and formatting in the WordPress editor. Am I doing something wrong or have the settings changed within the last year. If they’ve changed, how do I change them back to regain the proper spacing?

    The blog I need help with is davesdominion.wordpress.com.

    #954732

    timethief
    Member

    Do this first please:
    Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

    Then see here please:
    http://en.support.wordpress.com/posts/#publish-a-new-post
    Microsoft WORD is not web compliant code and when copying and pasting text from WORD we must use icon icon 6 in Row 2 of the visual editor > http://en.support.wordpress.com/visual-editor/#pasting-text

    Hopefully, the information linked to below may help you:
    (2) If you are working in the Visual editor, to get single spacing between paragraphs hold the SHIFT key down and simultaneously click ENTER at the end of the paragraph. If you are working in the HTML editor, a single click of ENTER will give you a single-spaced line, and two clicks of ENTER will result in double spaced lines. http://onecoolsitebloggingtips.com/2011/09/13/wordpress-formatting-and-spacing/
    See also > http://en.support.wordpress.com/writing-and-formatting-poetry/

    #954746

    davekellogg
    Member

    Thanks…The SHIFT+ENTER by itself doesn’t work but I can do that plus a regular Enter and it inserts the space between the paragraphs.

    #954750

    timethief
    Member

    I’m glad to read you have worked this out.
    P.S. I’m pretty sure justpi will be along later with more information.

    #954838

    justpi
    Member

    More information requires a published post, so we can check its code and see what’s wrong.

    #955044

    davekellogg
    Member

    Here’s a link to the published post.

    http://davesdominion.wordpress.com/2012/07/24/test-2/

    #955045

    davekellogg
    Member

    In the Visual editor, there are spaces after the definition I have at the top and then between and after the two paragraphs.

    #955046

    justpi
    Member

    You need to edit the post, switch the editor to “Text” (formerly “HTML”) and delete all of these:

    <div style="text-align:left;">
    <div>
    </div>

    Then switch back to Visual, select Paragraph from the Format tool (row 2 tool 1) and you’ll be able to add paragraph breaks the normal way.

    In the future
    a) make sure the Format tool is set to Paragraph before you start typing,
    b) never copypaste from other sources into the Visual editor, as it introduces bad code that messes things up: when you have to copypaste, paste into the “Text” editor, so that only the text will be pasted.

    #955047

    davekellogg
    Member

    Thanks, that worked.

    How did that happen in the first place, though. The last time I posted, which was admittedly about nine months ago, it was working just fine.

The topic ‘Paragraph spacing?’ is closed to new replies.