paragraph spacing suddenly stopped working

  • Author
  • #600570


    Today the spacing between my paragraphs suddenly stopped working. It looked fine in edit mode (using several hard returns to move the text down to where I wanted it positioned between photos) but then in preview and published modes all of the extra hard returns disappeared. As you can see in today’s post, I finally reverted to putting a “-” on each line I wanted for spacing just to get the text where I wanted it.

    Help please!

    The blog I need help with is


    Sometimes this happens when the editor gets out of “paragraph” mode. This can happen when you copy and paste from another program or from the web and it brings in strange code that messes things up. Sometimes it just happens though.

    Open the post in the editor, select everything in the post and then from the “format” pulldown at the left end of the lower row of icons in the visual editor, select “paragraph” and then save. If that does not work, then we will need a link to the post so that we can take a look.



    Thanks for the quick reply. I couldn’t find format anywhere and I happened to click on kitchen sink — voila! (that was my first problem, not everything was showing) Then I highlighted all and clicked on paragraph — no change, still wasn’t inserting the spaces I wanted. Then, I was exploring parts of the kitchen sink I didn’t know existed before (because they were hidden) and saw “remove formatting.” I highlighted all, removed formatting, then highlighted all and clicked paragraph and it worked!!



    You are welcome, and sorry, I should have included a link to the visual editor support document that shows where all those icons are and about the kitchen sink icon.

    Glad you got it sorted out. My next suggestion would have been the “remove formatting” option.



    Ah! Assistance! Neither of those worked!



    I don’t see any spacing problems in your posts. Could you be more specific than “That didn’t help?”



    Hi I really need help :)

    I have followed instructions above but for some reason it is not working for me.

    Everytime I update how i want it to look it then click publish it goes back all over the place. It was working before not sure what has changed.

    Help would be much appreciated. Thanks



    The blog linked to your username is empty. I suspect you could be posting to the wrong support forum. Please read this and if you are asking about a wordpress.ORG install rather than a free hosted wordpress.COM blog then post to http://wordpress.ORG/support/




    @raincoaster-I’m trying to get extra spaces between some of the lines. I was hoping it would be more broken, like stanzas.

    @timethief-I looked at that section, and it’s mostly showing you how to make line breaks without spaces between them..which is the opposite problem. : /

    I really appreciate your guys’ help on this!!



    I’m having the same problem too. Tried all of the above methods, and nothing seems to work. The post two prior to today’s has the formatting I’ve been using all along, which is what I would like to stick with. If anyone has any ideas, let me know! Thanks!


    @instolenmoments, standard paragraph spacing in web standards is one blank line between paragraphs. If you want more than that, you have to use inline CSS. Paste the following into the HTML tab on a draft post and then preview.

    ‘<p>This is a line of text
    This is a line with no space inbetween and a standard paragraph break after</p>
    <p style=”margin-bottom:60px;”>This is another line (paragraph) with a large space below</p>
    <p>This is another line</p>’

    The inline CSS (the style stuff above in the opening “p” tag has to be done from within the HTML tab in the editor, and the 60px value adjusted as you desire. I just used a huge number for clarity when you preview.


    Gaaahhhh! I messed up on the backticks.

    <p>This is a line of text
    This is a line with no space inbetween and a standard paragraph break after</p>
    <p style="margin-bottom:60px;">This is another line (paragraph) with a large space below</p>
    <p>This is another line</p>


    After my initial fix I kept having the same problem. I discovered that AFTER I’ve uploaded all of my photos and typed all of my text, THEN I have to remove the formatting, choose paragraph (actually, that’s the default so I don’t have to click on it unless I want to make doubly sure it’s on paragraph), and THEN work on getting the spacing I want.

    For some reason, whenever I upload photos it seems to put in some funky code I don’t want but waiting until all texts/photos are in and then removing formatting and then making it look visually how I want works.



    Still, none of those options are working for me…



    I’m suddenly having two issues.

    I’ve been using the following snippet of code for maybe 3 months – exactly the same in every post. No problems – it creates the space just as it should.

    <p style="padding-top: 36px;"></p>

    Today, when I enter it in the html editor, check the visual and then save, the code gets stripped out.

    Also, the only way to get a paragraph break in the visual editor is to place the cursor one space in, make the break and then re-enter the missing letter. If I hit enter multiple times, <p></p> shows in the html editor multiple times, but it doesn’t appear in the visual editor or the saved draft preview.

    I don’t paste from Word or any of that – what am I missing?


    Nothing is working for me either….no spacing in anything I write. Was working until a couple days ago. Haven’t done anything different then what I normally do either



    After you selected all (ctrl A) and clicked on delete formatting, did you then select all again and click on paragraph (even if it was already on paragraph)? I found I had to do this to give it new formatting.



    I’m having the same problem. I’m trying to use <p>, but it’s not having any effect when I publish the post.



    i’m having the hardest time getting this post spaced out. i’m cut and pasting an interview from my email and anytime i go to publish or preview it squashes all the paragraphs together and looks like crap. i tried everything mentioned and nothing has worked so far.

The topic ‘paragraph spacing suddenly stopped working’ is closed to new replies.