Paragraphs and Line-Breaks Hair-Tearing

  • Author
  • #181901


    I don’t know if this is a Mac-specific issue, or a browser-specific one, but I’m having real problems with paragraph and line formatting when submitting and editing posts on my blog. The problem is, even in Code view, paragraph <p> tags aren’t displayed, so it’s really hard to work out where line breaks or paragraph breaks actually occur. When it comes to line-spacing, what I see in the editing window often seems very different from what I see when I view the site, which is very frustrating.

    I’m mainly using FireFox under MacOS X 10.5.1
    In Safari 3.0.4 on the same machine, the problem is even more evident.
    My blog ( ) uses the ‘redoable light’ theme (not sure if this is relevant).



    If you are using FF (and that was not a typo) upgrade to FF Some people with FF (mac and pc) and even IE7 have been having this problem where they weren’t before, but it is very sporatic. In other words, not everyone on those browsers is having the problem.

    Safari is an issue right now because the TinyMCE online editor wordpress uses is not yet compatible with Safari, but TinyMCE is working on it.

    If you are using FF (not then my suggestion is to switch to an offline blog editor. Qumana is quite nice, and a free download that works with Mac. Ecto is another good offline editor that works with Mac although it is not free. There is also ScribeFire, which is an offline editor plugin for Firefox. Since none of these use he TinyMCE editor in wordpress, your formatting issues should go away.



    Hi thesacredpath,

    thanks for your reply. I will investigate your suggestions. I’m glad it’s not just me, anyway!





    Every now and again, like right now, stops using P tags and switches to Div tags. I don’t know why, and it messes up the spacing but if you go in and edit the tags to P tags, it works.



    I’ve had the same problem with getting paragraphs breaks to happen. Glad to know it isn’t me… and hoping for a fix to come soon.




    This same problem drives me INSANE, and I, too, am on a Mac (though using the very latest verison of FireFox). Sometimes it works to manually enter the code below, suggested by another poster, and insert a paragraph return right after it on the code page (I know, I know, but it works)… and sometimes it doesn’t work and is automatically scrubbed next time I open the edit box:


    I’ve noticed one possible explanation: it *may* be the return stays if you do not edit that particular paragraph. But if you make any changes in it at all, the extra return will disappear and you have to insert it again. Or I may be imaging it. Like I said, this problem has driven me insane…

    By the way, I have great luck on Mac using a free WYSIWYG html editor called Nvu, but few other people seem to have heard of it. It’s been awhile since it was updated, so maybe it was abandoned, but it works great for me as a way to toggle back and forth between code and visual editing, then I paste the resulting code into the Word Press code box when I edit blog pages.


    Glad to see this topic – I thought it was just me. Today was the first time I wrote and posted a blog entry from the Mac (using Safari) – I’ve always used a PC (using IE) in the past.

    It wasn’t just the empty returns that were vanishing – I put in < p > tags, but they vanished too.

    I don’t have enough hair to tear out, so I was very happy to find a quick confirmation of the problem.

    I think I’ll use PC+IE again :)



    OMGoodness I am em so glad /em to see this topic. I thought I was going out of my mind because of the vanishing < p > tags. NOT switching to pc and/or IE. Will suffer through without breaks for now.

    Until someone figures something out??? (hoping it’s being looked at)

    Or will do posts with bullets for a while because those seem to be working. (readers will love that – ha)


    This issue has caused me to spout a flow of four-letter words at my new Mac. I didn’t know if it was just me or if it was just Mac in general. Glad to see I’m not totally inept at blogging with my Mac.

    I don’t want to go back to PC, but at the same time, it’s really important for me to have a clear ending and beginning for paragraphs!

    Would someone PLEASE figure out what to do to have ‘graph breaks?


    The TinyMCE editor that wordpress uses for writing pages and posts is not fully compatible with Safari and you will find problems in other areas as well.

    I would suggest downloading the Firefox or Camino or Flock browsers as they are the most compatible with wordpress.


    Alternately, you can go to “my profile” in the upper right of your dashboard and uncheck “use visual rich text editor,” click “update profile and then you will be doing all your writing in code view. Some, including myself, find this a little confusing since in addition to the text of your post, you will see all the html code for your formatting.

    Another alternative is to use an offline blog editor. Timethief has rounded up all the most popular editors and listed them on her resources blog at:



    Whew, sure am glad to know that others are facing this problem. I have noticed the P tags being replaced by Div tags and as a result the spaces between images has become a big problem. Nothing you do in the Visual editor works. All pictures just stick together and it looks really bad.
    Then after reading some of the forum posts this is what I did: I got rid of all Div tags, came to Visual view, increased the spacing and saved the post. This worked. So thanks. :)



    I’ve found something easy which works… just leave a mark of some kind between paragraphs in the colour of your theme. Mine is white, so I leave a white period between paragraphs. I can actually adjust the size of the spacing by adjusting the font size of the white mark, and after you’ve done it once you can copy and paste it wherever you need it…



    That’s clever. You can change the colour of marks by using the code (if you know it) or by using the Advanced Toolbar, which you get by clicking the last icon on the right above the Write box.


    This problem with the formatting just started today with the post I am trying to draft today. All previous posts formatted fine. I use Ubuntu Linux with Firefox however, so its not just a Mac problem. After reading all responses, I’ve gone back and changed the div tags to p tags. That fixed the problem but it is a real hassle.



    I have this problem, too, and it is driving me nuts. I use a PC and IE. I have finally given up on correcting messed up spacing, especially, on some posts that really need to be formatted, but it’s just too aggravating and time-consuming to spend all that time dinking around with code.


    Sadly wordpress seems bent and determined to replace paragraph “p” tags with div tags randomly. The only suggestion I have is to bypass the wordpress editor and go with an offline blog editor. BlogDesk and Windows Live Writer are free and work very well with Windows.



    I’m happy to see it wasn’t just me being a technological “ill litter rat” — b/c I’m having my own issues. I’m using Safari, and all I want to do is create some kind of breather-space for readers with paragraph breaks or line breaks, or something.

    Can someone explain how I can do this in really really really easy terms? If I have to get to the point of “offline blog editing” and “changing browsers” and “code” then I may go into “so freaking overwhelmed”-mode and cower in a corner, whimpering (rather than blogging) (or, I may just keep my blog a bundle of words, together, huddled for warmth in this big blog world…)




    Try Firefox or Camino. They play nicer with TinyMCE (the online editor we use). Or you can use an offline blogging program. I don’t do Mac, so I can’t recommend any. Search the forums, Mac people have recommended some.

The topic ‘Paragraphs and Line-Breaks Hair-Tearing’ is closed to new replies.