Paragraphs go away when publishing

  • Author
  • #191371


    Hey. I am new to blogging. Anyway, I am trying to set up my first post, but when I write a paragraph and press enter to leave a line open and start a new paragraph, this happens. The problem is when I publish it, the paragraphs are all gone and the sentences are all connected. Please help! Thanks


    What is the URL of your blog, and what browser/version and operating system are you using?



    I have the exactly same problem. My URL is and the browser that I’m using is Safari for iMac. Can you please help me. My blog is really hard to read without any paragraphs.


    The TinyMCE editor that wordpress uses for writing pages and posts is not fully compatible with Safari and you will find problems in other areas as well.

    I would suggest downloading the Firefox or Camino or Flock browsers as they are the most compatible with wordpress.


    Alternately, you can go to “my profile” in the upper right of your dashboard and uncheck “use visual rich text editor,” click “update profile and then you will be doing all your writing in code view. Some, including myself, find this a little confusing since in addition to the text of your post, you will see all the html code for your formatting.

    Another alternative is to use an offline blog editor. Timethief has rounded up all the most popular editors and listed them on her resources blog at:



    Problem solved, thanks a lot!!! It’s very important that there’s someone who knows how to help with these problems and is willing to do it!!!


    hhmm..See, im using my Mac too and ive tried both Safari and Firefox and if I put in “Enter” after a paragraph, once I publish, it takes it away. Ive tried to go in code and put in <BR> or <p></p> and it just ignores those commands.


    @alkemisti, glad this are now working for you

    @illegalprelude, try using the self-closing break tag and see if that works for you<br /> Otherwise in Firefox, you might try going to users > your profile and deselecting “use visual rich text editor” and the clicking “update profile.” The write a new draft post and save it. Then go back and select “use visual rich text editor” again and click “update profile” and open and work with the draft post you saved. I had one person tell me things started working for them after they did that.

    The editor seems to have some “issues” right now and I’m not sure what it’s all about.


    I’m having the same problem — if I use the rich text editor my code changes disappear; if I don’t,
    and <p> get ignored. I’ve tried turning the rich text editor on and off as suggested and it hasn’t helped.

    My blog is and the post I’m having problems with is . I’m getting very frustrated by this.


    Adding this, since I didn’t see the ‘backticks for code’ thing (my bad, didn’t look). It’s ignoring ‘
    ‘ and ‘<p>’.

    Thank you!


    Hm. It works better when I use the right key. That’s <br /> and <p>.

    This time, for sure!



    It’s a known bug as people keep telling us, but I get round it by making my last ‘chore’ to go to code view and put Enter Enter at each intended paragraph break. Then publish direct from there. Pays to have checked every last letter and space for errors first – because actually the most annoying thing is to have to do this workaround twice!! Fingers crossed they’ll sort it out soon.

The topic ‘Paragraphs go away when publishing’ is closed to new replies.